Menu
Reply
Geoghs
  • 13
  • 0
  • 1
Tuning in
254 Views
Message 1 of 27
Flag for a moderator

Port Forwarding when SuperHub is in Modem mode not working

I previously used SuperHub in router mode with port forwarding working uneventfully. I then decided to use it in Modem mode and connect it to an Asus mesh network to fix the appalling wifi. Port forwarding now doesn't seem to work.

Setup is:
Internet>>>SuperHub>>Asus>>Switch>>Everything on my network
(Also tried just the 2 devices connected to the router without a switch in between)

Devices that need port forwarding to work are Desktop PC and a NAS (VPN service). The services on the devices have remained unchanged and the ports are correctly configured in the Asus router but any connection from outside the LAN times out.

If I try using the website https://canyouseeme.org/ it tells me that the ports are closed.

All devices on the network have internet access. The DynDNS service is correctly updating my external IP address.

Looking deeper into the router settings, it seems that the WAN IP address that the router is using is a "private" IP address in the range 192.168.100.x but my IP address when I use https://www.whatismyip.com/ is coming up as a "proper" IP address 82.x.x.x.

It seems that the SuperHub is doing some sort of NAT, converting an external IP to an internal IP despite me wanting it to work only as a modem. Is there anyway that this can be turned off or is there some other workaround to allow port forwarding to work properly?

Thanks.

 

 

0 Kudos
Reply
gary_dexter
  • 28.91K
  • 1.77K
  • 3.78K
Alessandro Volta
245 Views
Message 2 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

It won't be the hub - in Modem Mode it is just that - a "dumb" modem.

*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
Geoghs
  • 13
  • 0
  • 1
Tuning in
233 Views
Message 3 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

That's what I thought too. But reading around it does seem that the modem mode (aka bridge mode) isn't configured as a true bridge in the SH.

 

If there is anyone out there who has successfully setup port forwarding on their own router with the Superhub in modem mode, I'd be grateful for their help. 

0 Kudos
Reply
gary_dexter
  • 28.91K
  • 1.77K
  • 3.78K
Alessandro Volta
229 Views
Message 4 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

I run an ASUS GT-AC2900 and have port forwarding setup for my Xbox - works fine.

*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
tehwolf
  • 1.57K
  • 253
  • 379
Superfast
225 Views
Message 5 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

No issues with port forwarding here - though i don't use an ASUS device..

idk about ASUS, but do you need a corresponding firewall rule to allow the traffic through (in addition to the port forward) or does it take care of that for you automatically when you create the portforward??

it's also odd that your ASUS is reporting a 192.168.100.x/24 address - whilst there is some trickery going on with that range when in modem mode, the WAN IP of your router should be reporting the public IP address, not the 192 address.. 

0 Kudos
Reply
Geoghs
  • 13
  • 0
  • 1
Tuning in
218 Views
Message 6 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

Yeah, that seems to be the problem. I'm having an email discussion with ASUS to see if there is anything funny going on with their kit.

0 Kudos
Reply
spgray
  • 2.39K
  • 139
  • 338
Problem sorter
216 Views
Message 7 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working


@Geoghs wrote:

That's what I thought too. But reading around it does seem that the modem mode (aka bridge mode) isn't configured as a true bridge in the SH.

 

If there is anyone out there who has successfully setup port forwarding on their own router with the Superhub in modem mode, I'd be grateful for their help. 


works fine for me with hub in modem mode using an Asus RT-AX88U.


-----------------------------------------------------------

My Broadband Ping - spgray

0 Kudos
Reply
tehwolf
  • 1.57K
  • 253
  • 379
Superfast
215 Views
Message 8 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working


@Geoghs wrote:

Yeah, that seems to be the problem. I'm having an email discussion with ASUS to see if there is anything funny going on with their kit.


tbh i'd probably just reboot it all... switch the hub and the asus off, then switch the hub back on, wait for it to settle (few mins) then switch the asus back on and see if you get the proper address on the WAN side..

0 Kudos
Reply
Geoghs
  • 13
  • 0
  • 1
Tuning in
206 Views
Message 9 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

Will try that when I get home...... 

0 Kudos
Reply
Geoghs
  • 13
  • 0
  • 1
Tuning in
198 Views
Message 10 of 27
Flag for a moderator

Re: Port Forwarding when SuperHub is in Modem mode not working

Internet is working for me, just not port forwarding.

Is port forwarding working for you? What setting have you used for obtaining the WAN address?

 

Thanks.

0 Kudos
Reply