cancel
Showing results for 
Search instead for 
Did you mean: 

Port Forwarding page broken

devbrodie
Joining in

I have 2 servers in my network which I expose to the internet via port forwarding.

One of these devices used to have the internal IP of 192.168.0.6, but I have recently changed it's IP address to 192.168.0.5.

Today I opened the port forwarding page on the router and deleted the old rule and tried to create a new rule for the new IP address.

When entering the IP address, the router's script logic tells me that 192.168.0.5 is not a valid IP address!

As such, I cannot add the new rule which means my service is no longer visible to the Internet.

I tried speaking with VM tech support, but the people I dealt with obviously don't have a clue about port forwarding because they kept telling me that my routers IP address is 192.168.0.1 - yeah, they were that good!

Screenshot 2023-02-24 143644.png

25 REPLIES 25

Client62
Hero

Does the Hub expect the 192.168.0.5 IP to be on the DHCP reserved list before it will accept the port forward.

no - I dont use DHCP on the router anyway - never have, I use my pi-hole for DHCP

Tudor
Very Insightful Person
Very Insightful Person

Your picture does not contain any port numbers, perhaps that’s the problem and it’s an error in the message given.


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

yeah - I know it doesnt - that's not the problem. It's the fact that the page thinks that 192.168.0.5 isn't a valid IP.

The screen shot was just to show the error

trust me, I've used this for years. I know how port forwarding is supposed to work. If the stupid page wasn't using JavaScript to detect for a valid IP, then it wouldn't block you from going any further

Try forwarding to an ip inside the DHCP range (even though the DHCP server is not enabled). It sounds stupid, but some firmwares are stupid. 🙂

192.168.0.5 is in the range. I have 50+ device in my network. My DHCP leases starts at 192.168.0.2 and ends at 250. I reserve IPs between 0.2 and 200 - Anything outside that range is a device which I dont "control" - i.e. a guest mobile/tablet etc.

Its not the IP address that's wrong - its the VM router web page - there's obviously been an update and that has included a javascript file which is trying to validate the entered IP and getting it wrong.

If VM weren't so flipping controlling with their router this wouldn't be an issue

 

 

If the bug is only in the javascript, you could fiddle around with it a little (using the browser's web developer).

The DHCP scope is a thing in other firmwares. The RDK-B firmware will not forward to an ip outside of it, but not the issue here, I see.

It makes no difference what IP I enter - it says that are all wrong...

devbrodie_0-1677256284010.pngdevbrodie_1-1677256299377.pngdevbrodie_2-1677256312182.png

devbrodie_3-1677256871781.png

devbrodie_4-1677256886684.png

 

 

I've been trying that for most of the day - I'm not a programmer, so I can find the variable in the HTML which it looks at, but then can't find that in the JavaScript file - There's 6 or 7 js files - I think the correct one is the "base.js" file, but can't find where it does the validation.