Menu
Reply
  • 1
  • 0
  • 7
phpcodemonkey
Joining in
3,107 Views
Message 51 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

So, there is a workaround available for this issue (The local ports between x and x on IP x.x.x.x have been added as virtual server already, please try another one.):

It seems that it is possible to get the port forwarding to work (as in it does forwards ports at the network). However, the UI to set forwards up doesn't work very well. This issue comes from a bug caused by a naive test in the JavaScript validation (so it could be fixed by a firmware update!).

The workaround, while a little annoying, seems to work reliably. You need to add the required ports in a sequence of lowest to highest, within each IP address/protocol combination. So, for example, let's say I want to add ports 4500, 500, 8080 for UDP to IP 192.168.0.10 - to achieve this add them, so the overview table results in the sequence:

192.168.0.10 500-500 500-500 UDP
192.168.0.10 4500-4500 4500-4500 UDP
192.168.0.10 8080-8080 8080-8080 UDP

The annoying part is that if you want to insert a lower numbered port, you have to delete the higher ones for that IP address, add the lower port sequence and then re-add the higher ones back in - a little tedious but it works none-the-less.

  • 15
  • 0
  • 0
PeteSpringfield
Joining in
3,065 Views
Message 52 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Just wanted to say thanks for that very helpful workaround.

Appreciate you taking the time to post it.

All the best,

0 Kudos
Reply
  • 4
  • 0
  • 0
MaskeryM
Joining in
2,919 Views
Message 53 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

I seem to have the inverse of what everyone else is suffering from. I recently set up port forwarding for a Plex server and during testing I used one of the online port scanning tools to test if the port was open. It was but so were http (80) and https (443). As I'd never checked before, I wondered if they were somehow open by default so I disabled my port forwarding rule and ports 80 and 443 are now closed.

The rule I set up was a single port 32400-32400 internal and 32400-32400 external.

Any ideas out there?

0 Kudos
Reply
  • 1
  • 0
  • 0
ubigian
Joining in
2,791 Views
Message 54 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Thank you very much, phpcodemonkey!!!

Your solution work like charm!!!

You are ways better than virgins engineers!!!

0 Kudos
Reply
  • 6
  • 0
  • 0
actualmanx
Tuning in
2,545 Views
Message 55 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Thank You @phpcodemonkey

This worked for me.
Had to delete a load of ports to set this up but is now working i was using all tcp ports.

 

So, there is a workaround available for this issue (The local ports between x and x on IP x.x.x.x have been added as virtual server already, please try another one.):

It seems that it is possible to get the port forwarding to work (as in it does forwards ports at the network). However, the UI to set forwards up doesn't work very well. This issue comes from a bug caused by a naive test in the JavaScript validation (so it could be fixed by a firmware update!).

The workaround, while a little annoying, seems to work reliably. You need to add the required ports in a sequence of lowest to highest, within each IP address/protocol combination. So, for example, let's say I want to add ports 4500, 500, 8080 for UDP to IP 192.168.0.10 - to achieve this add them, so the overview table results in the sequence:

192.168.0.10 500-500 500-500 UDP
192.168.0.10 4500-4500 4500-4500 UDP
192.168.0.10 8080-8080 8080-8080 UDP

The annoying part is that if you want to insert a lower numbered port, you have to delete the higher ones for that IP address, add the lower port sequence and then re-add the higher ones back in - a little tedious but it works none-the-less.

0 Kudos
Reply
  • 11
  • 0
  • 5
flashware
On our wavelength
2,327 Views
Message 56 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Just another reply to say this workaround worked a treat for me too. Usually I would enter the ports in ascending order anyway, so don't know why I didn't this time round! If I didn't, I wouldn't have known there was an issue at least I guess 😉
0 Kudos
Reply
  • 7
  • 0
  • 0
jarjartee
Tuning in
2,230 Views
Message 57 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Hello there - pretty cheesed off now really - hope you might be able to help ??

had a replacement for our failing Superhub2 this morning  - technician installed SuperHub3 very swift - all works apart from ONE crucial feature - port forwarding. 

I have a small Raspberry 3B web server that has been working fine (and still is) up until this morning at the switchover of hubs. I dialled in all the details that I used from Superhub2 to open ports 22, 80 and 443 for IP address 192.168.0.100. This is now NOT working at all ; I have specified static IP in both web server and sHub3 + forwarded all ports correctly as I did with sHub2. Please help if you know what the issue is (all was working fine up until this morning) 😡  

Tried DMZ / port trigger / Firewall off etc - zilch response  - appreciate response if possible

0 Kudos
Reply
  • 9.07K
  • 249
  • 546
Forum Team (Retired) Nat_J
Forum Team (Retired)
2,223 Views
Message 58 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

Hi jarjartee,

 

I've responded to your separate thread regarding this.

 

Nat_J


Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 1
  • 0
  • 0
theriddlerz
Joining in
1,888 Views
Message 59 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

hey matte did u no that v.m changed router groups too just incase u still stuggling in most of the other stuff just after router manger page changed too

0 Kudos
Reply
  • 1
  • 0
  • 0
bowson
Settling in
1,745 Views
Message 60 of 66
Flag for a moderator

Re: Port Forwarding on Hub 3

seems problems are still occurring with SH3. Just received mine today as upgraded to VIVID350 and can't get any port forwarding working, nothing in this thread seems to have helped..

anyone still listening hear that can help?

0 Kudos
Reply