Menu
Reply
  • 3
  • 0
  • 0
RPurton1
Joining in
976 Views
Message 31 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

Sorry forgot to add the whole set information....

1) Virgin Super Hub 3

Connected to..... 

2) D-Link Gigabit Unmanaged Metal Desktop Switch DGS-108

Which is then sharing the internet by.....

3) 4 x BT Whole Home Wi-Fi

 

 

0 Kudos
Reply
  • 1.77K
  • 99
  • 326
Adduxi
Super solver
972 Views
Message 32 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

You still need a Router if using the Hub 3 in Modem Mode .......

0 Kudos
Reply
  • 12.53K
  • 479
  • 1.12K
legacy1
Alessandro Volta
979 Views
Message 33 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work


@RPurton1 wrote:

Sorry forgot to add the whole set information....

1) Virgin Super Hub 3

Connected to..... 

2) D-Link Gigabit Unmanaged Metal Desktop Switch DGS-108

Which is then sharing the internet by.....

3) 4 x BT Whole Home Wi-Fi


You still need a type of NAT to split your one WAN IP on one MAC to other devices the simplest that you get a NAT router.

 

0 Kudos
Reply
  • 57
  • 0
  • 1
Forum Team
Forum Team
967 Views
Message 34 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

Thanks for clarifying on your equipment, Richard.

You can get some help on this as you send a text to our technical team on 07533051809. The team is available between 8am and 7pm Mondays through Fridays.

Alternatively, for more advise on your setup, we can do this via online chat.

Ning_Q

 

0 Kudos
Reply
  • 4.58K
  • 309
  • 764
Roger_Gooner
Superstar
965 Views
Message 35 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

If you need a mid-range router the Archer C8 (see my sig) works well.

As Adduxi said, you need the switch after the router. You must have one of these configurations:

Hub in Router Mode -----> Switch ------> BT WH

Hub in Modem Mode -----> Router ------> Switch ------> BT WH

Make sure that the hub is connected to the router's WAN port and that all three cables are cat 5e or cat 6.

You’ll probably want to turn off the Wi-Fi on your router as the BT WH creates its own WiFi network rather than extending your existing network.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
  • 6
  • 0
  • 2
k3nw00d
Tuning in
917 Views
Message 36 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

Had Virgin installed yersterday and was given the Hub 3, first thing on my agenda was to change to Modem Mode and keep my existing router (Netgear WNDR4500) doing the NAT, DHCP, etc...

Couldn't get it to work last night, so gave up after an hour and came across this thread today, the below steps work to a degree:

1.Go back to router mode

2.Plug your router that you'll be using into one of the ports (doesn't matter which, but I used the very bottom one)

3.Set your router to get it's WAN address via DHCP (it might to this automatically, but check)

4.Verify that your router is getting an internal IP address (192.168.0.X, where X is a number greater than 1)

5.Connect a device to your router

6.Navigate to the Virgin SuperHub interface and set it to Modem Mode

7.Wait for it to come back up, and then refresh the connection on your router to make it pick up the WAN IP address

8.It should work

Initially my Router gets an IP Address and connect to the internet with Hub 3 in router mode, as modem mode disables DHCP you lose that address and does not pick up another, so I entered the static of what I was assigned by DHCP, no internet, then I remembered the address of the Hub 3 changes to 192.168.100.1, so changed my static to a 192.168.100.x address, no internet...  It is like I cannot get past the Hub 3 to pick up an external IP Address.

The only way I can get Internet to work is as Hub 3 as a router,, not a modem which is not an issue.... Until that is I try and connect to my QNAP NAS remotely (Outside my Network), this fails as you cannot have 2 NAT devices between the QNAPCloud and the NAS.

How can I get the Modem Mode to work correctly so only 1 router is in the mix ?

Cheers in advance 🙂

0 Kudos
Reply
  • 12.53K
  • 479
  • 1.12K
legacy1
Alessandro Volta
913 Views
Message 37 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

When you put the hub in modem mode wait a bit then power off for 2mins then on and make your router set to DHCP to get a WAN IP.

If that don't work connect a PC to the modem mode port in modem mode to get a WAN IP and then copy the PC MAC to your router WAN settings.

 

  • 3.93K
  • 466
  • 1.26K
Very Insightful Person
Very Insightful Person
907 Views
Message 38 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

@k3nw00d I my experience of connecting two different Netgear routers (including one similar to yours) the routers handled the DHCP without any manual intervention on my part and picked up the Internet connection without any hiccups.

I have heard that some routers can be fussy about the startup sequence of the devices.  Some need the hub to be fully powered up in modem mode and finished it's startup routines before powering up the router, for some I think it is the other way round. 

Netgear's support pages suggest using the Setup Wizard:

https://kb.netgear.com/22697/How-to-configure-your-NETGEAR-router-for-cable-internet-connection-with...

I can't remember if I used the Wizard or not, I setup my current router with a VM hub in modem mode 5 years ago and have not had to redo the setup since.  When I moved from a Super hub 2 to the current Hub 3 I just plugged in my router and it worked.  Always use the bottom Ethernet port on the hub as that is the only one that should be working in modem mode.

______________________
Scott

Disclaimer - I don't work for Virgin Media. I'm just another VM user trying to help out so my answers may be wrong Smiley Happy If my answer solves your problem please mark it as helpful as it may help others
My setup: Vivid 200 Optical fibre with Hub 3 in modem mode connected to a Netgear R7000 router. Telewest/VM user since 2001.

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

 

Mark as Helpful Answer if I've helped

  • 4.58K
  • 309
  • 764
Roger_Gooner
Superstar
884 Views
Message 39 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

Put  the hub into modem mode and wait for the base light to turn magenta. Connect the router by its WAN port to the hub and power it on. The router will get its WAN IP address and its local IP address is (for my Archer C8) 192.168.1.1. It's DHCP server is normally enabled by default but occasionally you'll need to log in and enable it. It's pretty much plug and play, no setting of IP addresses needed.

Some people advocate powering on the router before the hub but I've done it the way I've described for a long time without a problem.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
  • 6
  • 0
  • 2
k3nw00d
Tuning in
868 Views
Message 40 of 51
Flag for a moderator

Re: Modem mode on Hub3 does not work

Thank you for the replies, I have tried all and still no joy.

My Router's WAN RJ45 is connected to RJ45 port at bottom next to Coaxial cable to Hub 3.

Set to Modem Mode, waited 5 mins, powered off for 5 mins, powered on waited 5 mins, no change

In modem mode the light goes magenta and the Hub3 has 192.168.100.1 address

Set back to Router Mode and my router gets an IP address and Internet.

Set back to Modem Mode, all looks okay on Hub 3, powered off my router, waited and powered on again, no internet and no IP Address.

Ran Setup Wizard, it kept failing and would not complete as could not get Internet access.

With my router powered on I put Hub 3 back into router mode, Internet access immediately.

Not really sure what to try next, if I could change the actual IP Address of the Hub 3 to my routers assigned IP range it would be fine, I would piggy back the routers, I already have that setup with on older router to extend my WiFi range (everything is disabled and it's gateway is my main routers address), I can't change to the 192.168 as I have approx 80+ networked devices in my home (Sonos, Philips Hue, QNAP NAS, ESXi Hosts with several VM servers and desktops, etc) so too many to start changing (I am an IT Contractor to trade, which is why this is baffling me, I know networking well, but this is just mad)

Anything else I may have missed ?

Cheers again 🙂

0 Kudos
Reply