Menu
Reply
  • 1
  • 0
  • 0
77andyb
Joining in
65 Views
Message 1 of 2
Flag for a moderator

Macbook can't see 5Ghz wifi channels above about 50

Hi, bit of a newbie with this sort of thing so please be gentle! I think I'm using a Superhub 2 or 2AC, not sure which.

Anyway, I noticed recently that an Ookla speedtest done on my Macbook was regularly showing speeds of around 40 to 50mbps. Bizarrely, when I use my mobile phone to check, it usually gets close to 100 or over. I think my top speed should be about 150. After following a friend's advice, I checked local traffic using a wifi analyzer app. I also used a utility on my mac to show surrounding networks, and could see that 4 or 5 other networks are broadcasting on channel 40, as am I (although when logged in to the hub, this shows as 44+48. Not sure why the difference. Friend suggested I could try higher channels. I moved my channel up to something in the 50s or 60s and saved the changes.

After waiting some time and checking, my network was no longer showing, so I couldn't connect to it. It didn't show on either my phone (a pretty recent one, Samsung S8+) and my Mac, but my network just wasn't visible. Luckily my router is set to broadcast at 2.4Ghz as well as 5Ghz, so I was able to log on to the visible 2.4Ghz channel, log back into the router, and restore the original settings.

So I am wondering about 2 things; Why can't my devices see channels above 48, so that I can move to a less 'crowded' area, and why on my current settings does my mobile phone give a much, much higher speed when tested than my Macbook does? Not only that, but I have a Windows laptop I use for work, which also shows much higher speeds than my Mac.

If anyone can suggest anything else at all to try to improve the speed my Macbook achieves, I'd be very grateful. 

0 Kudos
Reply
  • 10.15K
  • 898
  • 2.17K
Superuser
Superuser
28 Views
Message 2 of 2
Flag for a moderator

Re: Macbook can't see 5Ghz wifi channels above about 50

The channels above 48 are subject to Dynamic Frequency Selection and Total Power Control to avoid possible interference to Weather Radar and Military Applications (which the military don't use anymore.)

Some wireless vendors initially disabled the higher channels rather than implement the DFS and TPC software due to the confusion over the regulations. I don't know if this is the case anymore since the advent of the Wireless AC standard and the ever increasing popularity of the 5Ghz band, but I have seen some devices struggle with the higher channels. (Some further reading here). It might be worth trawling a few Mac Forums to get further info. on what channels the MBP can use and for known problems with MBPs wireless.

As it stands, a wireless access point needs to scan for 60secs, on channels 52 to 116 and 10mins on channels 120 to 140 before it can start transmitting.

The Hub is in channel bonding mode, bonding two 20Mhz channels (44 + 48) to form a 40Mhz wide channel to increase the data it can carry. This will give a LINK speed of 150Mbps (75 - 90Mbps actual speed) per wireless stream.

The speed will vary due to environmental factors like range, interference, the topography of your home and the number of antennae the wireless client has. The other networks on channel 40 will not be interfering with your connection as they are using a channel which does not interfere with the channels you are using, so there is no need to change channel because of these networks.

The Samsung S8 may have a wireless adapter with two 5Ghz antennae (MIMO) which will increase the speed of the wireless. (The Hub will have to be set to use MIMO, the upto 450Mbps setting on the SH2 and upto 1.3Gbps on the SH2AC. There should be a sticker on the base of the Hub to tell you which model it is. VMDG 485 = SH2 VMDG 490 = SH2AC

I would check the capability of the wireless adapter in the MBP.

You could also download WifiAnalyser for the phone to check if the Hub is broadcasting on the higher channels.

It would be worth checking the actual Internet speed by testing with a device equipped with a Gigabit Ethernet card connected directly to the Hub by Cat5E or better Ethernet cable.

0 Kudos
Reply