Showing results for 
Search instead for 
Did you mean: 

Issue with Teams

Tuning in

Hi there, first time post! I’ve had an issue with having video calls in Microsoft Teams, I’ve read the forums and can see this is a known issue with the Hub3 and/or downstream.

my speed is 200mb and fairly solid, the problem only occurs when having video calls in teams (audio calls seem to be fine). 

The router is around 5 meters away and I still get around 150mb speeds! This problem only happens when I am at home and doesn’t happen with other WiFi providers.

Some advice I have seen on here suggests that I should disable the firewall, I am worried about doing this so grateful if virgin media could get in contact please to help? This is affecting my, and my wife’s ability to work.


Very Insightful Person
Very Insightful Person
See this.

If it is a wifi only issue, then all you can do on a Hub3/4 is to try separating the SSID's of the 2.4 and 5 GHz wifi bands by renaming them in the settings and at the same time switch off "channel optimisation" apply and save the settings. All wifi devices will need reconnecting to the best SSID at each location. Also use a wifi scanning App to find the best wifi channels to use (just select and use channels 1,6,11 on 2.4GHz) - this often helps Hub3 users get better wifi performance - but its still no substitute for getting better kit 🙂

To address the wifi, VM now supply “wifi Pods” (no longer doing “boosters”). Pods are only free to customers on 1GB, Ultimate Oomph or Volt packages - is that you?

If not… you will be charged £5/month - note that BT charge £10/month for their wifi solution. . Its a simple solution and should work for you. However, you would soon pay off that cost by buying a "better" wireless solution that will be yours to own and use forever but it isn’t the simple plug and play option of the Pod(s).


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 1 WiFi, 1 on PA) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's. On 250Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Thanks for your reply and update, ALotey,


Are you able to confirm if this is only occurring on wifi? If so then there may be several factors that can impact wifi signals such as, where the hub is located, objects surrounding the hub, wall density, reflective surfaces, radio interference from other electrical devices and others. These things will not be picked up by our diagnostics and would not be a connectivity issue that can be escalated.  In some instances,  our wifi pods may be needed based on these factors.


Other solutions such as the one offered by jbrennand, may also help with wireless connection.



Corey C

im having same problem, my teams shows dropped packets, it does not say what is dropping the packets but appears to be virgin media hub. i wonder if its got filtering or some other clever thing on it that stops teams udp packets.

I have come back to Virgin after some years with BT.

We left Virgin last time because the quality of broadband was poor, but thought that with the wizzo speeds now offered and a very good deal it would be much better.

TV great beside the router, internet in my study a floor up and a bit away only serviceable - Teams and other video conferencing poor. Like using Teams through a 4G phone connection with regular drop-outs. Speedtest shows a jittery 75Mbps in my study with a ping of 16ms. That should be more than enough for video conferencing, but it regularly freezes. This is with an extender pod on the landing about 6 metres away, albeit around a corner. 

Looks like a crappy service that will have to be terminated.

OK but don’t leave it too long, remember that you only have 14 days from installation to be able to cancel without penalty. Now, I’ll be blunt and honest but you aren’t the first and certainly won’t be the last to confuse raw headline speed with quality or reliability of a service. In terms of speed, 10-20 Mb/s will suffice for a single ‘Teams’ call, the vagaries and basic ‘crappiness’ of Teams itself notwithstanding - what will kill it though is latency, and more importantly, jitter, and in this respect the technology that VM use doesn’t cover itself with glory in that respect.

A far slower (on paper) FTTC connection via Openreach is likely to have a much more stable latency figure and give vastly better performance for ‘time sensitive’ usages, such as video conferencing, VoIP etc. It’s not that VM are necessarily doing anything wrong, it’s just a limitation of the technologies they are currently using.

Now for some reason, the WiFi provision from all of the VM hubs, is ‘absolutely first class’ - said nobody ever! Not sure why, as WiFi is constrained by international standards, maybe poor design or build quality of the hubs, but this is something you can do something about by, alas, spending more money and getting your own equipment, a decent router or even a mesh system. But, latency issues, sorry but there is absolutely nothing you can do, or realistically VM can do, well not without spending a shed load of money, which, frankly isn’t going to happen?

So you need to decide whether to stay or leave, but it won’t mysteriously get any better, what you are experiencing now is as good as you are going to get!


Hey Heatonfan,

Welcome back to the community and thanks for taking the time to post.
I’m sorry to hear of the issues that you’re having with your connection at the moment, I have looked into your account and cannot see any issues that would be causing the problems. I can see that another pod has been ordered, have you been able to get that pod activated and if so has it improved your connection?

Kind Regards,