Menu
Reply
Beigemaster
  • 5
  • 0
  • 0
Joining in
82 Views
Message 1 of 2
Flag for a moderator

Internet not working on some connected devices both Cable and WiFi

Hi all.

I now have multiple devices connected to the router (both wireless and via CAT cables) which appear as connected to devices, but report on the device as "Connected but no internet". They are 

  • A Samsung smart phone
  • A LG Smart TV
  • An Amazon Kindle

All of these devices work with no issues if I connect them via my iPhone hot spot- so this is definitely an issue with the Virgin network not the devices themselves. Also, all my Windows and IOS devices (both wired and wireless) run off the router with no issues at all.

Things I have tried (so far)

  • Simple rooter reboot
  • Checked that devices can be seen connected to the router via app and router pages (they can)
  • Hard reset (factory default) rooter
  • MAC filter set to "disable"
  • All local firewall settings set to "off"
  • All Virgin Media account firewall settings set to "off"
  • Tried with UNPnP off and on
  • Made sure no devices were "paused" via the app (they weren't)
  • Made sure no devices are blocked on the router's page

I'm getting more and more frustrated with this situation (the TV was the very frustrating as had to piggy back off my hotspot just to get the TV registered on first install) because this is definitely something specific to Virgin that's blocking an internet connection (it's not just a wireless dead spot problem as it happens on hardwired connections) to these devices as they all work independently and I really don't want to have to go through a very long support call with an engineer to explain all of the 'fixes' that I know they'll ask me to do. Again, my Windows and IOS devices all work fine.

I like Virgin Media and I like the speeds I get on the devices that it doesn't block, but if I can't resolve this then I will have to try a new supplier.

If anyone could offer something I've missed then that would be much appreciated- please remember this affects wired connections as well so please don't advise about things being too close to microwaves or granite walls etc! 

Thank you  

0 Kudos
Reply
Beigemaster
  • 5
  • 0
  • 0
Joining in
30 Views
Message 2 of 2
Flag for a moderator

Re: Internet not working on some connected devices both Cable and WiFi

UPDATE- some issues now resolved 

Appreciate I didn't get any responses- but just in case someone does a google search for this and wants to know how some issues can be resolved....

  • LG TV- plug in via CAT cable, go to "Network Settings" and disable IPv6 (google suggests the Hub 3.0 doesn't support IP 6 so this seemed to resolve it)
  • Amazon Kindle, turn off "Location Services", again, no idea why Virgin Hub was blocking the internet gateway because of this but hey ho
  • Samsung phone- switch to static IP

Seems that all these little quirks were causing the hub to block the devices- I say "some" now resolved as the TV still doesn't connect via WiFi, but cable is fine. 

0 Kudos
Reply