Showing results for 
Search instead for 
Did you mean: 

Hub5 samsung s20 will not connect to wifi

Joining in

Installed new hub5 with WiFi 6 yesterday. All devices ok except Samsung galaxy s20 which does not connect to WiFi, either manually or via qr code. All other devices that connected to previous hub are working fine, including iPhone, galaxy s22 ultra and galaxy tab. Any ideas?


Forum Team
Forum Team

Hi awthomson, 

Thanks for your post and welcome to the forums. It's great having you on board with us in the Community. 

I'm sorry to hear you're having an issue connecting your Samsung S20 device to your WiFi. 

When searching for the network in the settings, are you finding it? If so what happens when you try to join it? Does it gie you the option of entering in the passphrase?

Pop back and let us know. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Yes, finds the SSID, and lets me enter password, but still doesn't work.

I must reiterate this device worked perfectly well on the previous router which we had last week before this new one was installed.

Very Insightful Person
Very Insightful Person

Try setting the 2.4Ghz band to a legacy setting as below:

Access your Hub by navigating to
Login with the default login info (on base of Hub) unless you've already updated it.
Go to Advanced Settings > Wireless > Wireless signal
In the Wireless frequency 2.4GHz select Wireless mode > 802.11b/g/n/ax mixed
Select Apply changes

It may be your s20 does not like the ax wifi 6 protocol ?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Will give that a try and let you know

Tried that, it knocked all devices off the internet so changed settings back

Thank you for the update @awthomson.

Is this the only device you are having issues with? Also, are you able to check that airplane and offline modes are deactivated on your device? Have you also tried rebooting your device to see if the issue persists? 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Airplane mode not on. Like I said, all other devices worked before and after hub replacement- xbox, androids, ipad, iPhone, firestick, TV- just this one device that doesn't connect.

Hi awthomson,

Thanks for coming back to us - has this worked since posting? If not, can the device see the broadband and just not connect, or not pick it up at all?


Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

It finds the wifi ssid, I enter the password, it tries several times saying "connecting", then eventually fails stating "connection failed". I haven't changed any settings on the hub, and apart from this phone every device that worked on the old hub works on the new one. It's the only Samsung galaxy s20 in the house.