cancel
Showing results for 
Search instead for 
Did you mean: 

Hub3: Issues accessing multiple websites and services

Synthesis
Joining in

For about a few months I've had issues accessing basic websites such as Amazon Prime Video, and payment systems on multiple companies such as Crocs, Lakeland, and Air France. As well as accessing services like Steam, Discord voice chat, and Epic Game Launcher sign-in.

It's so bad that I have to hotspot onto my phone just to get a connection otherwise the request just doesn't get actioned. I had this problem a few months ago but it somehow resolved itself but now it's back with revenge.

I've tried placing my desktop outside the DMZ in the Hub 3 settings but it changed nothing. I have Pi-hole setup but I tried resetting everything to run on the Hub 3 and it still changed nothing. Restoring the Hub 3 to factory settings doesn't change anything which all leads me to think the problem isn't on my end.

This problem affects everyday usage and it has got to the point where I bought an aftermarket router. Otherwise, I can't wait to get out of the contract term just so I can leave without the early exit fees as this is just so frustrating.

8 REPLIES 8

Client62
Legend

It is always very risky to assume an ISP issue when your own ad-blocker / router are involved.

With the Hub in Router mode, configure your computer to use Google Public DNS & make sure the computer's Gateway is 192.168.0.1,  does that improve the access to these websites ?

If it was my ad blockers then hot-spotting onto my phone's 5g wouldn't fix it. My DNS is set to my Pi-hole which is set to Cloudflare and Google's DNS servers. As stated above, I have tried resetting my configuration so that it's just the router acting as DHCP server and 8.8.8.8, 8.8.4.4, 1.1.1.1 rather than using the Pi-hole for DHCP and DNS server for my network.

I think it is fair to say it is the ISP that's the issue.

Hi @Synthesis 

Thanks for posting and welcome back to the community.

Apologies to hear of these broadband issues.

Can you confirm, have you tried it without any third party equipment, purely in router mode?

Do you get any error messages when you try and access these sites?

Best wishes.

John_GS
Forum Team


Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

legacy1
Alessandro Volta

your new router might fix it with new IP or see if modem mode with a PC works first 

---------------------------------------------------------------

Most of the time I don't get an error message, sometimes I get a connection timeout. But on services like Discord Voice, I just get stuck in a connecting and disconnected loop for about 10 minutes.

Adduxi
Very Insightful Person
Very Insightful Person

Go back to basics maybe?  Factory reset the Hub and connect your PC only.  Set the PC up for DHCP from the Hub.  Does this work? Can you disable any web blocking software you are using.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

I’ve already tried all of the above. This forum and a new router are my last resorts.

We wouldn't be able to support or assist with 3rd party equipment @Synthesis 

Do you have the same access issues when you have our router solely in modem mode with an ethernet cable to a device without any software which might also affect requesting access to sites like Steam and Discord? 

Here to help 🙂
Virgin Media Forums Agent
Carley