Showing results for 
Search instead for 
Did you mean: 

Hub 5 reset Subnet IP's changed

Up to speed

I’m having the same problem for some reason the hub5 has switched to using the sun net of instead of  and now refuses to issue IP addresses and the virgin middleware has completely messed the factory reset not rectifying anything.  



[MOD EDIT: Subject title changed for clarity and post split to own thread]


It’s in router mode but wireless is turned off as the hub won’t save Wi-Fi details correctly and causes problems, along with the dhcp / ip address issue. 

Hi @pogit1 thanks for your reply here, sorry this is still causing you issues.

I can see that you have recently been in touch, has this since resolved things for you?

If you need any further assistance, please don't hesitate to let us know!

Many thanks


@tom_w1 thanks for checking in sadly after another hub5 and a knowledgeable installer visit no things haven’t improved the second you try to change something simple as the Wi-Fi name or password from the default the hub5(s) go haywire, not giving both bands the same details so causing Wi-Fi devices not to connect and messing with the DCHP/DNS release and reissue process.

This is confirmed by both people in Virgin who basically say the only option is to not use the hub 5 as a router just use it in modem mode with my own router or trying to become a business customer though I’m told there’s the backup line is even worse with that option.  

However I reluctantly temporarily tuned DHCP OFF on the hub5 using another local device as a DHCP server and point it away from Virgins DNS servers ( and to Google or Cloudfare DNS servers which compromises things and puts my device vis-à-vis on the internet which I’m not happy about and it’s disabled virgin safety apps and other features. 

So basically it’s confirmed yet again Virgin has crippled yet another Superhub which is genuinely a good bit of kit with is **bleep** poor middleware, the only reason more people haven’t complained is because the majority of customers plug and play not changing anything but I am planning on moving away from Virgin as soon as practically possible hence going back to using a custom Wi-Fi name so it stays the same no matter which provider I’m with which is why I moved away from virgin email years ago when that was started to be used as blackmail to keep me with the company. 

It’s such a shame Virgin the company treats both its customers and its knowledgable staff like crap! Virgin used the on be and could still be the best ISP in the UK but they insist on not spending money where it’s needed and the very basic is if you want your hub to say Virgin Media in the set up process you can’t do it on the cheap by people who clearly have no bloody idea what they’re doing! Changing Wi-Fi name is so basic is unreal that this cause the hub5 to fail, and blaming customers for wanting to change something so basic is just wrong, I'm glad I'm no longer advertising I’m a virgin media customer and the amount of people that I’ve previously never spoken to who have seen I’ve had issues and have also said oh your virgins playing up too is truly shocking,  Virgin Media board members should be extremely worried about the mass exidus of customers when City Fibre has finished installing their network here as I alone now many people that are leaving as soon as possible, but maybe that’s part of the plan. 

All this hassle because of a forced phone line swap, is truly unbelievable. Sorry for the long rant but I’ve kept it short and to the point as possible, and I genuinely don’t hold anything against VM staff who in the main have tried to be very helpful bht have had their hands tied. 

Please ensure my comments are put into an official complaint and raised at the highest level because it’s just unacceptable for this to be a thing, and the DNS issue is a major thing and probably why VM is having problems at national level no wonder IP6 stil isn’t a thing rolled out on the network when you can’t even get IP4 correct which is 40 years old now. 

Again thank you for checking in but it’s nothing any customer or none high ranking VM staff member can fix

On our wavelength

Got exactly the same issues. I was hoping firmware updates may have fixed it but NO!

Forum Team
Forum Team

I am so sorry to hear that things have not improved and that you are feeling let down @pogit1 

I would be happy to raise a complaint for you via a Private Message. I will pop you a PM across now, please keep an eye out for the envelope at the top of your screen alerting you to a new message.