Showing results for 
Search instead for 
Did you mean: 

Hub 5 no longer recognising switch

Tuning in


Got a Hub 5 a few weeks ago (upgraded from Hub 3) and I have a Netgear GS105 switch connected directly to the router.
All had been working fine, until I returned from holiday yesterday and the switch was no longer recognised. I've done some troubleshooting on the switch (working fine) and tried with another known working switch (a TP-Link TL-SG108S) and got the same. I know nothing has changed at my end (as no one has been here to change anything!), and connecting directly into a laptop's ethernet port works fine - it appears to be specific to the switches.

Additional info: I've done the reset that tends to be the default VM response, and WIFI is unaffected 

Thanks Greg


Alessandro Volta

Get a router with 1Gb ports use hub in modem mode


Forum Team
Forum Team

Hi there @gregpalin 

Thank you so much for your post and welcome back to the forums, it's great to have you back. 

I am so sorry that you have faced this issue and thank you again for popping back, can I just confirm, are any other devices beside switches facing issue? Have you tried a full factory reset at all to reconnect?

To do this push a pen etc into the reset hole at the back of the Hub and hold in for 60 seconds, this will force a full factory reset so any changed Hub setting will revert to the originals but you can change this back after. 

Very Insightful Person
Very Insightful Person

You tried connecting with a new Cat6a ethernet cable? - old ones do "fail".


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Alessandro Volta

The hub with its limitation allow you to connect a switch to hub and one source MAC for devices to switch


In router mode? Are you saying that Hub can't handle more than a single wired device?

The router is used for both wired and wireless connections 

As the original post says:

"Additional info: I've done the reset that tends to be the default VM response"

Everything has been tested. Other cables have been tried.

This is a brand new router that had been working fine with the switch for several weeks. This is a fault rather than a limitation.