Showing results for 
Search instead for 
Did you mean: 

Hub 5 and TP-Link Archer c6 V2 very slow speeds

Joining in

I have recently moved to a Virgin media home hub 5 on the 1Gbps package.

When using the hub directly, I get 850Mbps on cat6 ethernet cable or 750Mbps on 5ghz wi-fi. 

>> Internet > Hub in router mode > Laptop

When I set the hub to modem mode and connect to my Archer v6 via cat6 ethernet cable, I only get 80Mbps down on wi-fi and 120Mbps on cat6 ethernet. When I connect directly to the hub in modem mode, I'm still getting 850Mbps on cat6 ethernet. 

>> Internet > Hub in modem mode > Router > Laptop

I have checked all the settings on my router and nothing should be causing this throttling. I have replaced the ethernet cables with brand new cat6 cables and this is still not working. I have confirmed the issue on three different laptops (windows 10 & 11) and two mobiles (android and apple). I have also tried AP mode and get the same issue.

At all times I am using the 2.5Gbps port on the hub, but have tried the other 1Mbps ports with the same issue.

Any ideas how I can fix this? It feels like the hub is throttling my connection somewhere!



Having confirmed the speed is available at the Hub.
It reads like the Archer Router is limiting the performance. Check QoS / DPI are fully disabled.

Alessandro Volta

might be a faulty TP-Link or try copying your PC MAC to your router and see what hapens