Showing results for 
Search instead for 
Did you mean: 

Hub 5 and Samsung pad

Joining in

Hi, recently upgraded to 1TB broadband and was sent a new hub 5.  All the devices in the home (Apple & android) seem to be working ok via wifi but for my Samsung Galaxy Tab A 2016 model.  It won't connect to the internet even though it shows connected by wifi, it hangs and then fails with various messages.  I see from various posts on this forum it's an on-going issue that would still seem to be unresolved.  The pad worked on our previous hub (3?) and since experiencing this problem I have used it on another Virgin broadband network with another type of hub successfully, so I know it's not the devise.   So, apart from buying a new pad (which one will work?) or a wifi boost? which I shouldn't need because all other devises seem to be working, what would the Virgin media team/community suggest?



Accepted Solutions

On our wavelength

I have a Samsung tab a 2016 (Software Version T580XXS5CTK1/T580BTU5CTK1/ Security patch level 1 April 2020) too and just received a Hub 5 tonight and plugged it in. I came from a hub 3 with no issues with the tablet.

I too was having the same slow loads or showing as connected with no internet so have split the hub to show 2.4 and 5ghz with separate SSIDs. To do this name them differently. I so I call my SSID's the same just add 2.4ghz and 5ghz at the end.

Now the tablet is working after i connected to the 2.4ghz SSID. Albeit not on the 5ghz.

The 5ghz which didn't work was 802.11a/n/ac/ax mixed WPA2-PSK the 2.4ghz that worked was 802.11g/n/ax mixed WPA2-PSK

My question is what is the latest firmware version for the hub 5 could it be that I and the original poster (@vernh) have old firmwares and our routers just need a firmware pushed to them? I currently have hub 5 software version LG-RDK_3.18.30-2112.12


I note other posts across the forum reference samsung connection problems to the hub 5.


See where this Helpful Answer was posted


Forum Team
Forum Team

Hi Vernh,

Thank you for your post and welcome to the community. 

I'm very sorry to hear about the issue with your tablet. 

Can you confirm the tablet has the latest update?

Also can you confirm the Operating system it is currently on?

Can you also confirm the specific error messages you're getting?


Joining in

Hi, the Samsung Galaxy Tab A 2016 running Android 8.1.0, Samsung experience version 9.5, it has auto update on but last update seems to be April 2020.  No messages other when a site can't be reached such as the short cut for the user manual or a very long delay as trying to connect to the Virginmedia home page.  I have just attempted to Facebook and the page has not loaded but connected very slowly after refreshing the page.




Thank you @Vernh


I'm so sorry to hear that this has happened! 


Just to make sure, is the device now connected but loading slowly? 


Thanks again. 

Hi, yes the pad wifi is showing connected but it loads very slowly or not at all.  Clicking on links in emails are the same.



Forum Team
Forum Team

Thanks for the update Vernh,

We have checked and the issue with the Samsung Galaxy A tab and this issue seems to have been resolved in July, so there should be no problem with this device connecting to your hub 5.

Have things improved since your last post or is it still struggling to connect and load?

Kind regards Jodi. 


Hi, seems to work sometimes in that the other evening I was able to access Facebook and read the posts but not access any reels.  I read the email notification for your response just now but it stalled when I attempted to connect via the link.  I am replying using the home computer which is hard wired. Is there any setting in the pad I need to check?  I am running Mcafee virus protection on the pad.



Hi Vernh, thanks for the message. 

Thanks for the message and sorry to hear that you are having issues with the Samsung pad and Hub 5. 

Can you confirm if this is still an issue since posting? 

Can you confirm if the tablet is running the latest update?

Kind regards, Chris. 



Hi, still loading very slowly.  Just went on to Facebook and it took at least 30 seconds to load the header. Even as I write this reply only the first 3 posts were loaded after minutes.  I have just selected share on a post and only got drop down box populated after 30 seconds.  I am using Samsung internet app.  Loading via firefox is equally slow.  According to Play store I have the latest version update 1 Nov 2022 for Samsung.  Is there anything else I should be checking?  I know it's not the pad as it loaded and worked perfectly through a wifi hot spot on my Samsung phone on Sunday and a couple of weekends ago I used it on another Virgin user's wifi who has an earlier version Hub.




Hi Vernh, thanks for the message and welcome back to the forums. 

Can you clear the cache and cookies, confirm if this is the only device affected, do alternative browsers help at all and does this happen at a particular time of the day?

Kind regards, Chris.