Showing results for 
Search instead for 
Did you mean: 

Hub 5, Wireless SSID’s and DHCP…

Tuning in

Hi everyone, and hello VM if you're reading this,


I'm a long-time VM subscriber and a former employee, and I've generally enjoyed using the platform without any major issues. However, I've recently encountered some problems with the new Hub 5 that I'd like to share with others who may be experiencing similar issues.


I believe that the firmware issues on the Hub 5 have caused several problems that are not likely due to the original hardware provided by Sagemcom. This reminds me of how VM used their outdated TiVo software on new Liberty Global hardware, which resulted in a slow and buggy TV interface.


It seems that the developers working on these firmware updates have made some mistakes, either because they are inexperienced or because they are trying to simplify the interface and functionality for the sake of user-friendliness and security. Unfortunately, this has led to some serious problems with the Hub 5.


Here are the issues I've been facing:


I've removed my previous Google Wi-Fi mesh and connected a 2.5 GbE Ethernet cable via a couple of unmanaged switches. When I change the SSID from the default one, the network fails, and DHCP becomes unavailable. After some experimentation, I found that giving unique SSIDs to the 2.4 GHz and 5 GHz radios resolves the issue. However, this setup causes the VM Connection app and the WiFi SuperPod to malfunction, as they seem to require matching SSIDs for the two radios.


There could be a few reasons for this issue:


Each radio has its own DHCP server, leading to IP conflicts when the SSIDs are the same.

Both radios share a single DHCP server, but there is an IP or port conflict that prevents clients from connecting.

There may be a conflict with the public-facing WiFi or the Hub 5's guest network DHCP.

As a temporary solution, I'm using a third-party device to handle DHCP. I would like to continue using the Hub 5's WiFi 6 capabilities, as the hardware is actually quite good when it's not hindered by VM's firmware.


Another issue I've encountered is with the WiFi SuperPods. They could be very useful if they worked with separate SSIDs, but they don't. Also, the SuperPods seem to have only 1 GbE Ethernet ports or disabled 2.5 GbE ports, which limits their usefulness in a mesh network, especially in large houses with thick walls.


It seems like VM either opted for a less capable version from Plume or messed up the firmware, disabling the 2.5 GbE functionality. VM should consider allowing customers to use their own DOCSIS 3.1 CPEs, like the Sagemcom 3896AX, Motorola MB8611, or ARRIS Surfboard S33, which have better hardware and firmware.


I hope VM addresses these issues soon, or they may risk losing loyal customers who have been with them for many years. I've been with VM for 27 years and would rather not switch to another provider, but if these issues aren't resolved soon, I may have no choice.


Why is it that other ISPs and TV providers using Sagemcom CPE hardware don't seem to have these problems? VM, please fix these issues or allow us to use stock firmware or an expert option to bypass the problematic aspects of your firmware.


Tuning in

Hi All, and Hi VM if your Listening… 

As i think some others may have had these issues, I thought i would add too it also,

I am long time VM Sub and Ex-Employee of VM, I’ve always been a person who loves the platform and never really had many issues, Apart from the No Technical scripted offshore staff who now have my job!

But that being said, The hardly any issues issue has arised with this Hub 5... 

I don't know what VM's shoddy firmware has done to Sagemcom's poor hardware but they are completely screwed it,  I am almost 100% sure Sagemcom didn't provide VM with so many issues with such basic features of a CPE Modem Router AP Combo product.  This takes be back to VM running their old Legacy Flash Based TiVo software on the newer Liberty Global hardware for years making people suffer with slow sluggish TV interface and bugs galore rather than just running the Horizon Software like every other Liberty Global company was worldwide without issues.

I wonder what kind of Dev's are building these firmware,   Yes i understand for the business they need to minimize the Interfaces of their devices so that they can be easy to use for all customers,  Especially elderly and disabled customers,  and yes I also understand reducing the Technical Feature Set for peace of mind of no security issues, or other network issues caused by clever people who might set something up that could work well for them but could cause other issues on the platform for others.    Some routing option are best hidden, Specially  for some who think they understand more technical features better tgan they really do.

But come on VM REALLY,   What have you gone and done to the poor Hub 5???

So as with others here the issues I’ve having.

(Note:  I have removed my Previous Google Wi-Fi 7 Node Mesh,  and I just have a 2.5gbe Ethernet running via a couple of 2.5gbe switches,  These are unmanaged switches,  So currently these is nothing on my Network that could interfeare with the Hub 5’s Basic Configuration,  But the issues I have occour without the Ethernet Connected anyways).

VM Hardware used is Hub 5 (FW: LG-RDK_4.6.24-2206.7) + 1x WiFi SuperPod for now!

So the Hub 5 works great out the box with VM’s Default SSID, and Password. Even the SuperPod works!

But the moment you change the SSID from the Default,  BLAM!  Network has failed and DHCP is no longer available,  What the hell…

So it didn’t take me long to play with setting to figure out what was going on, Well it’s one or two things (maybe a few) but hard to know which because of limited UI on the Hub 5,  So I noticed if I give the 2.4Ghz and the 5Ghz Radio’s unique SSID’s (WiFfi-2G & WiFi-5G) from eachother the network DHCP comes back up and everything works fine.

The VM Connection app HATE’s this and compain that the is a SSID Configuration Conflict and suggests two options to pick from to fix this,  But this just failed,   Stupid App based crap for router’s shouldn’t exist.. ☹

Plus with the configuration the WiFi SuperPod no longer connection,  and if I watch my WiFi Analyser,  you can see the SuperPod creating a unnamed network on 2.5ghz and 5Ghz and these pop up sit there for a while then disappear while they try again looking for the network.

So the VM Connect app and WiFi Pod’s  don’t want to work,   My guess is,  and pretty sure about this is that they both want the 2.4Ghz and 5Ghz Radios to have a matching SSID.

So what a believe is happening is either,

  • The two Radio’s (2.4Ghz & 5Ghz) both have there own DHCP Server’s (1 Shared Pool) and when they are names the same cause I conflict, Client’s try to connect, It connects to 1 of the 2 DHCP Servers,  Try to get an IP,  Client is acknowledged by 1 of the two DHCP Server’s and is assigned by the pool,  the second DHCP Server tried to do the same,  trying to assign it Another IP address,   or Rejecting the Client’s DHCP request as it see the IP is already in use.

  • The two radio’s (2.4Ghz & 5Ghz) share the same DHCP Server but cause a IP or Port Conflict rendering DHCP unreachable by any client devices

In both cases, Major error in the writing of the firmware on the Hub 5,  Come on VM it’s DHCP it isn’t hard ??

There is another couple of things that might be going on here too,

A Clash with their public facing WiFi “Virgin Media” DHCP.


A Clash with the Hub 5’s Guest Network DHCP.

On the Hub 5 I haven’t actually noticed the Public Network appear,  So either they haven’t Implemented it as of yet,   or that itself is also broken.

And I have the Guest Network disabled,   But known the issues with the older SuperHub 4 with the Guest Network Subnet issues

(Subnet IP Conflict where SuperHub 4 would still sit on, even if you change it two another Default IP, and Even if running in Modem Mode,   It would always have IP’s, which caused 3rd Party Router’s to have to 2 anything other than subnet range like or what ever else,  But this is an issue as so many 3rd party routers used by default causing an instant IP Conflict on there WAN Side,   This what caused by the Disabled Guest Network reserving that Subnet,  despite being Disabled,  and desite is using a different subnet once enabled)


So I assume with the Hub 5 the Guest Network is still doing something similar running its services (IP,  DHCP Etc) in the background while being disabled with just the Radio Access turned off.

So I looks like for now I’m going to have to run a 3rd Party device sitting on my network to handle DHCP for now!   I was hoping to try to just run the Hub 5,  and the WiFi SuperPod’s for a while to see how its run’s,    I have taken my Google WiFi mesh offline,  and I was having issues with one of the node’s plus it only has 1gbe on its WAN side,   so would never get the performance of my 1.2Gig VM Connection.

For now until I have the money so spend on a new 3rd Party WiFi 6E Mesh (Not App Based) I want to continue using the Hub 5’s WiFi 6,  As it actuly performs really well, which shows the Hardware is actually capable,  Its just limping along on VM’s crappy firmware.

Final Gripe,   The WiFi SuperPod’s,    If they worked on 2 SSID’s which they don’t,  they would really work well,   As these Plume Products are actually very good,  I was happy to use them in the mean time,   But I have always Backhauled my Mesh over Ethernet,  and I believe the VM one’s will backhaul over ethernet,   But only seem to have 1gbe ethernet ports on them,  Either than or the 2.5gbe is disabled,  I know Plume have 1 gbe version and there Super version has 2.5gbe,    I thought the VM SuperPod (SP01) [Dual Port] rather than WiFiPod(PP01)[Single Port] would be the same offering 2.5gbe,  It’s not so Super is it…  Mesh as good as it can be has losses,  specially in a very large Victorian house with triple brick thick walls,   and whats the point in backhauling 1gbe limiting the data rate to 960Mpps while offering 2.4Gbps Wireless bandwidth.

So either VM Cheaped out and got a less Super version from Plume,  or they screwed up more firmware disabling 2.5Gbe on the ports.

What are you doing VM ?  REALLY!

Maybe you need to consider allowing customers to eihers use your provided equipment or allow 3rd party DOCSIS 3.1 CPE’s to join your HFC Network,  So people like me can go out and buy an off the shelf solution,   say a . . . .    Sagemcom 3896AX, Motorola MB8611 or ARRIS Surfboard S33,   All very good hardward option,  All DOCSIS 3.1,  All WiFi 6 or Above,  All have no Screwy Firmwares.

We should be able to provide our own CPE Modem,  Other providers and even Liberty Global in other countries allow this,   I don’t know why you don’t allow us in the UK to do this also..

But please VM if your reading this, Get your Dev’s to fix these Continued Issues,   Maybe fire some Dev’s and get some new one’s,  There loads out there right now!,  Or just offer Stock Firmware or and Expert Option allowing to by-pass the VM Bugginess in the mean time….

It’s driving me Banana’s….

p.s.  How come Sky, BT or other ISPs/TV Providers use Sagemcom CPE Hardware and don’t mess it up so much?


Hopefully someone fixes something soon,  or your going to start loosing your faithful loyal customers who have been with you the longest.

I don’t really want to go near than BT’s Muck,  But unless stuff changes pretty soon my 27 Years on the Platform are going to go the way of the Dodo.


Tuning in


Very Insightful Person
Very Insightful Person
The issues are all bypassed when in modem mode with your own router and wireless equipment


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.


I understand this John,  But as i explained,  Until i can afford get a new Mesh System,

The provided equipment shouldn't have these faults to begin with and new resolving.

Very Insightful Person
Very Insightful Person
The way I call it is...

Yes... the VM equipment is not the most capable out there and its made even less so by their insistence on having control of everything through applying their own - frequently "buggy" firmware.

However the VM Hubs work perfectly well for the vast majority of their 5.5m subscribers. If they didnt you wouldnt be able to move on these fora for complaints. My mate around the corner thinks the Hub5 is the finest wifi router money can buy !

So until the all powerful VM Marketing Department calculate that they need to provide better quality equipment in order to stem the loss of customers leaving - and hence reducing revenues because of these issues - they simply wont sanction major spend on major improvements - but rather just introduce cheaper solutions like... smart wifi, wifiMax, Pods, etc.

I and many others are just glad that they still allow modem mode !


I do not work for VM. My services: HD TV on VIP (+ Sky Sports & Movies & BT sport), x3 V6 boxes (1 wired, 2 on WiFi) Hub5 in modem mode with Apple Airport Extreme Router +2 Airport Express's & TP-Link Archer C64 WAP. On Volt 350Mbps, Talk Anytime Phone, x2 Mobile SIM only iPhones.

Forum Team (Retired)
Forum Team (Retired)

Hi @Sean1983,

Thank you for your post 👋😊

I am sorry you are having issues with your hub 5, I have run some test our systems and all looks fine, with speed connection and upstream/downstream is there any particular issues you are having? Or are you unhappy with the equipment?


@Zoie_P wrote:

Hi @Sean1983,

Thank you for your post 👋😊

I am sorry you are having issues with your hub 5, I have run some test our systems and all looks fine, with speed connection and upstream/downstream is there any particular issues you are having? Or are you unhappy with the equipment?


the award for totally not reading anything & digging a big hole to stick her head in goes to 🥁🥁🥁 Zoie.

These problems have been reported by me & quite a few other VM customers ( and growing ) don’t you think it’s time you took the reports seriously?

Maybe send a few to whichever department needs to see them?

IF i have helped you, please give me kudos / mark me as helpful, thanks

Tests by system show fine so it must be fine.

Just adding that I'm experiencing these issues when trying to change the SSID to a custom SSID on our new Hub 5. Really frustrating, as the only way to seemingly get it working in my instance is to be using the default, and I'm not going to enjoy reconfiguring the multiple WiFi lights, sockets etc. around the house to those details. This really is a basic functionality that should just work for users of the hardware.