Showing results for 
Search instead for 
Did you mean: 

Hub 5 Issues - Multiple Devices Consistently Losing Connectivity

Tuning in

Hi.  I have recently upgraded to the Hub 5 with Gig1 and 2 Pods. I have circa 55-70 devices online at any one time, which the Hub 3 dealt with and rebooted when necessary, all coming back up and running successfully each time. However, I have had consistent issues since upgrading to the Hub 5. When I received the first hub I changed the settings to my Hub 3 wi-fi settings (expecting a smooth transition), but only a small number of devices connected (including the virgin boxes). 

The technician who came to the house to check the box, was dumbfounded when I proved this, but didn't have an answer and changed the Hub.  I tried to do the same on the 2nd Hub, with him there, but with the same result.  In the end I had to change the 2nd Hub back to factory default settings and change the wi-fi settings for all my devices which took hours, but they all connected independently.

It was stable for a couple of days, however it crashed and if I just left all devices up and running, as happened with the first hub and now 2nd hub, only a few connected and the rest can't obtain an IP address.  On 'experimenting' I have found that I need to switch off up to 45 of my devices, leaving around 30 up and running, reboot the hub, which does allow them all to connect when I switch them on again individually.  This is also a laborious, long task, but better than changing the wi-fi settings for them all all.

Annoyingly, I have lost connectivity twice in the last 24 hours, with only a few devices connected, so I have had to go through the whole process each time. I did phone the Virgin helpline the first time; he made some changes, but again the issue is still there and it crashed overnight.

It would appear that the Hub 5 is unable to connect to multiple devices, which would intimate either a hardware or software failure and or settings within the Hub 5, as I previously said the Hub 3 was fine.  I have spent at least 5 hours on the phone in all to Virgin, but after speaking to around 5 helpful (but unfortunately not fixing the issue) customer service reps, I am back to where I started with a very unstable Hub 5.  Is anyone else out there having similar issues, or has any ideas on how to resolve this please?  Many thanks.



With your high device count using the Hub 5 in Modem mode plus a 3rd party router maybe the answer.

Hub 5 has a raft of known defects, including WiFi that fails if the SSIDs are changed, and a DHCP server that is unreliable.

Hub 5 also suffers from Ghost calls on the VOIP telephone service.

Thanks for this. I presume using a 3rd party router makes the virgin pod's redundant?

I can confirm what your reporting sounds like the DHCP bug, though it sounds stupid keep turning “smart Wi-Fi” on/off whilst observing the connected devices list… that eventually works for me.

IF i have helped you, please give me kudos / mark me as helpful, thanks

Very Insightful Person
Very Insightful Person

"I presume using a 3rd party router makes the virgin pod's redundant?" Not quite, it still performs the DOCSIS modem function, but has a lot less tasks running so it works much better. I’ve always run all my VM hubs in modem mode.

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

The VM Pods will only work with a VM Hub in Router mode.

So a Router / Mesh might be required

Forum Team (Retired)
Forum Team (Retired)



Thanks for posting on our community forum


As advised above the VM pods would only work with a VM hub in router mode, my apologies for any inconvenience.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Tuning in

Any solution to the DHCP issue affecting the Hub 5 yet? A solution that doesn't involve letting Virgin media off the hook and buying my own router...

Tuning in

Hi, did Virgin find a solution to the DHCP fault with your Hub 5?

Hi. No. I am on my 3rd hub 5 (3rd one received 2 weeks ago) as the 2nd one was getting progressively worse, dropping out and not allowing me to get everything back online until up to 6 attempts of factory resetting each time. Initially, with the technician there, I changed the WiFi name and password to the old hub,  but nothing would connect as per the other two, so yet again I had to manually connectall 75 plus devices to the new hub.  It then wouldn't connect to any smart plugs, as the settings in the hub have been greyed out to stop the user turning off 5G and my phone will always pick up 5G (this restrictions wasn't there on the 1st hub 5 I received, so must be a recent software update). So, in the end I had to reconnect all my devices, and had to use 2 tp link extenders to cover all areas to allow me to connect my 2g smart devices. Another day wasted, because the hub 5 is not smart and has many flaws.  It actually hasn't crashed yet in 2 weeks, so I am not sure if it will simply reconnect all devices now I have 30 odd on the extenders, as there still may be too many for the hub to cope with on a reboot and I may still need to turn many devices off and factory reset it, for it to start reconnecting to the devices.