Menu
Reply
gary_dexter
  • 30.31K
  • 1.88K
  • 4.03K
Alessandro Volta
3,591 Views
Message 1 of 44
Flag for a moderator

Hub 4 Bugs/Glitches

Where and how is the best way to report any bugs and glitches I have found with the Hub 4?

Thanks,
Gary


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
Tudor
  • 8.12K
  • 649
  • 1.42K
Alessandro Volta
3,565 Views
Message 2 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

Perhaps you should at least let people on the board know of your experience and problems with the Hub4. It would seem that VM took little notice of problems discovered with the Hub3 and I’m not holding my breath that they will be any more efficient with this one. 


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
0 Kudos
Reply
gary_dexter
  • 30.31K
  • 1.88K
  • 4.03K
Alessandro Volta
3,560 Views
Message 3 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

OK. So discovered issues so far:

1. WiFi Channels switch between Manual and Auto randomly and with no rhyme or reason. If I set it to Auto, any time later it will change back to Manual, then back to Auto again sometime after that and so on. This happens on both the 2.4G and 5G bands

2. If you name the 2.4G and 5G networks the same, the password can only be amended in the 2.4G field - however it does not copy down to the 5G field so you end up with different passwords.

The only way to “fix” this is to add an extra random character on the 2.4G SSID name to then edit the 5G password field, then remove this extra character to make the names the same again then save. 

Until you do this your device will have difficulty in authenticating the password depending on what band it’s trying to connect to.

3. Making changes to the IPV4 Firewall page and clicking apply briefly flashes up options to amend the “IPV6” Firewall...

4. Under DHCP, you can amend the starting address to that of the router/gateway (e.g. 192.168.0.1), which inevitably locks you out of the hub and unable to access the GUI page requiring a pin-hole reset to “fix”.
On the Hub 3 you were unable to select .1 as a starting address and an error message would advise this 

5. Again under DHCP, amending the maximum number of CPE’s doesn’t always work/take effect, and if you choose an invalid number (example, 300) it just throws you back to the login screen without any error messages. Again the Hub 3 would tell you that the specified number was invalid

6. There is no Remote Login/Management option

7. Choosing to reboot the hub from the GUI takes you back to the login screen rather than showing a splash screen like the Hub 3 whilst the reboot takes place. The Hub does reboot still though. 

8. IP addresses are assigned with no rhyme or reason and randomly. Whereas on the Hub 3, if the starting address was .2, then the first device would get this .2 address, then the next device to connect would get .3, then the next .4 and so on. 
The Hub 4 seems completely random and assigns addresses randomly from .10/20/30/40 etc all the way up to 200 in no numerical or logical order or reason. 

9. When making and applying any changes, the Applying Settings wheel appears indefinitely and never goes away. The page has to be refreshed or a new tab opened and logged into the hub GUI to see if that change has actually taken effect. 

10. You cannot connect the Hub 4 to the Virgin Connect app. So I’m not sure how you are supposed to connect the supposedly free Gig1 WiFi Boosters as well?

11. There’s no “Smart/Intelligent WiFi”. 

This is all I’ve found in the 2-3 hours of running the Hub 4.

I will say that WiFi signal is an improvement over the Hub 3 and I’m getting slightly better 2.4G and 5G speeds where I wasn’t before, but not enough to warrant a major outcry of joy.

I’ll add more anomalies as I discover them though 🙂

Gary


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
Tudor
  • 8.12K
  • 649
  • 1.42K
Alessandro Volta
3,476 Views
Message 4 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

Great work. Would be good if you keep the list up to date with new problems and any that VM fix with firmware updates (if any!).


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
gary_dexter
  • 30.31K
  • 1.88K
  • 4.03K
Alessandro Volta
3,456 Views
Message 5 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

Thanks - will do.

Current software version on the Hub 4 is 01.02.024.18.EURO.PC20.


*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
0 Kudos
Reply
jb66
  • 12.14K
  • 898
  • 1.75K
Very Insightful Person
Very Insightful Person
3,258 Views
Message 6 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

10. You dont need the connect app to install boosters

11. Good!
Tudor
  • 8.12K
  • 649
  • 1.42K
Alessandro Volta
3,245 Views
Message 7 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

11 Good! Only if it’s not there at all. Could be it’s there with no setting to turn off, then it’s very bad.


Tudor
There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2
gary_dexter
  • 30.31K
  • 1.88K
  • 4.03K
Alessandro Volta
3,014 Views
Message 8 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

UPDATE - 05/05/20 - FIRMWARE UPDATE: 01.02.048.09.EURO.PC20

  • Login screen now hides the password by default with an option to “show” it
  • Router Status page doesn’t load from the login screen - you have to login and get it from the Tools page
  • Navigating to some pages (Firewall, Info and some others) then clicking to any other page can sometimes cause the page to become unresponsive and not load, meaning you have you close out of the session then load back on again to continue navigating
  • On the Wireless Security page there’s a title/heading mid-match between the 2.4G settings (2.4 GHz Wireless Security Settings) and the 5G settings (5 GHz WiFi configuration)
  • There is now an “Open Source Information” link next to the hub software version on the info page that takes you to a page with all of the source information for the update. Interesting if you like such things 🙂
  • Pre-RS errors still seem to “reset” when refreshing the status page
  • Network log appears up to date now - mine was always a week or so behind in updating 
  • Downstream status page now differentiates between DOCSIS 3.0 and 3.1 channels 

*****
If you think my answer has helped - please provide me with a Kudos rating and mark as Helpful Answer!!
I do not work for Virgin Media - all opinions expressed are of my own and all answers are provided from my own and past experiences.
Office 365, Dynamics CRM and Cloud Computing Jedi
jb66
  • 12.14K
  • 898
  • 1.75K
Very Insightful Person
Very Insightful Person
2,998 Views
Message 9 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

11. Brilliant, I want one

StormW4tch3r
  • 463
  • 10
  • 35
Superfast
2,937 Views
Message 10 of 44
Flag for a moderator

Re: Hub 4 Bugs/Glitches

I rebooted my Hub 4 and still on 01.02.024.18.EURO.PC20, will give it a couple days and try another reboot and see if it updates.

0 Kudos
Reply