cancel
Showing results for 
Search instead for 
Did you mean: 

Hub 3 solid red light

NICK_HOLDING
Joining in

My hub 3 has a solid red light.  Wifi is hardly working and on demand tv is not worth bothering with.  All this for 15% extra every month ££

all other posts point to an overheated hub, but it’s not that.  Can I just get a replacement please!!

1 ACCEPTED SOLUTION

Accepted Solutions

Adduxi
Very Insightful Person
Very Insightful Person

If the red led persists after a pinhole reset, the Hub will need to be replaced.  It is a risk having a faulty overheat warning.

Wait here a day or two and a VM Mod will pick this up.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

See where this Helpful Answer was posted

10 REPLIES 10

Adduxi
Very Insightful Person
Very Insightful Person

If the red led persists after a pinhole reset, the Hub will need to be replaced.  It is a risk having a faulty overheat warning.

Wait here a day or two and a VM Mod will pick this up.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Have restarted, reset, checked cables etc.  problem has been same for weeks

Hi @NICK_HOLDING 

Welcome to the community forums. 

Sorry to hear that you have a red light warning. Sometime this can be caused by a LED error rather than any issues with overheating and should also have no affect on the service. 

Please can you try a 60 second pin hole reset on the router. This will revert any customisations back to factory settings and full update the router with firmware/software updates. Please do not reboot the router whilst it is completing the pin hole request.

Please let us know if the red light is still showing after this specific pin hole reset and we'll investigate further if needed. 

Here to help 🙂
Virgin Media Forums Agent
Carley

Hi.  Have reset for 60+ seconds, and the red light remains on

I’m getting really fed up of this… on demand and catch up is pointless as wifi is hardly ever working.  Do I get a refund for this constant lack of service!

Natalie_L
Forum Team (Retired)
Forum Team (Retired)

Thank you for your reply NICK_HOLDING and for completing the reset. 

As the light is still showing, we will need to run a few additional checks. 

To do this, I will pop you over a private message to confirm a few details. 

Please check the red bar at the top of this page for a message from us. 

Thanks, 

 

 

Nat

I’ve got the same issue with my hub 3, solid red light and I’ve reset the router several times and removed Ethernet cable and reset it aswell. Still solid red light and terrible connection to wifi yet virgin do the checks and say it’s ok…

Hello Danielkey.

Thanks for your first post and welcome to our Community.
Sorry to hear you are having an issue with red light on your hub.
I'd like to take a look into this for you and swap the Hub over.

In the meantime can you please make sure the Hub is well ventilated and away from any direct source of heat.
If you don't mind, I will need to send you a private message to pass security. 
If you can check your Logo at the  top right of your screen that would be great. 
Regards     
Gareth_L
 

 

guitarmangler
Joining in

My hub 3 has also got a constant red light . I’ve tried the hub reset, and removing and putting back cables,  but persists. I’ve checked the connection and it seems one, but starting to have dropouts with wifi. Tried also to contact virgin media via their help page,  but all the links are broken!