Showing results for 
Search instead for 
Did you mean: 

Hub 3.0 setting log in page

Joining in

Hi everyone. Hoping for some help. Our internet disconnected a few nights ago. Happened about half midnight. I noticed the following day my usual internet connections weren’t showing as available. I’ve split the bands to 2.4GHz and 5GHz. I’ve realised that the Hub appears to have totally factory reset itself. It’s taken me a few days to get round to going back in to the settings to split the bands again. Here is where my problem is, I’m on the settings page (connected via Wi-Fi) it’s loaded up, asked for the language to be selected, I hit next and it says Update in progress, please wait before updating any settings and it’s been sat like this for over an hour now. Tried different browsers on my tablet I’m accessing the setting on and it’s still not doing anything. Cleared cache and cookies and both and restarted the browsers and not sure what else to do. I’ll need to call VirginMedia at some point to see what new deals I can get but I’m getting a bit sick of it now as we’ve had a few outages recently and now starting to wonder if it’s the hub that’s the issue as we’ve had it a fair few years now.


Forum Team
Forum Team

Hi there @walter44 

Thank you so much for your post and welcome to the community forums, it's great to have you here. 

I am so sorry that you are experiencing these issues with your Hub and the reset. Are you able to perform a full factory reset yourself? To do this push a pen etc into the reset hole and hold in for 60 seconds. If the bands are already split again this will reconnect them, but it may allow the update on the settings page to go through as well.