cancel
Showing results for 
Search instead for 
Did you mean: 

High speeds yet poor internet

Tomo28
Tuning in

Hi,

For about 6 days now I've been having internet issues. Certain sites will not load or will load extremely slowly. The virgin media connect app I'm using now to watch football now is saying my internet is poor quality and sometimes turns the stream off it has poor picture quality to.

Connecting to a vpn solves some issues. Mainly just reddit though. Without a vpn reddit can take minutes to load and buffers even the shortest videos.

Netflix and amazon prime seem to work fine. YouTube usually denotes 480p to start off with now also. 

The issues are present on wired and wireless devices. I have done various speed tests and packet loss test which show my connection speed is fine. My internal network is fine also with no packet loss. Everything has been rebooted to no avail. Pretty stumped to be honest as everything is saying it is fine but it is clearly not.

Any help would be appreciated.

 

23 REPLIES 23

Hi Tomo28 👋 thank you for keeping the thread updated. 

Fingers crossed 🤞 the engineer appointment went well. Having had a quick look it does seem the engineers / field team are aware of a wider network issue in the area which is the root cause of these faults and they are working hard to get this resolved as soon as possible. 
Thank you for your patience in the meantime! Please do keep us updated so we can continue to chase this with the area team for updates if needed. 
Wishing you all the best. 🌞

Molly

Hi Molly,

The engineer was very helpful and spoke to the wider team of engineers to confirm there was a fiber cable that was cut and not fully repaired. There was no known fix date unfortunately. However he did leave me his number and said I can give him a call if things don't improve within a week.

I have managed to get most of the stuff working by changing my DNS to cloudflare which is 1.1.1.1. I do still have unstable latency when getting to the first virgin media server however.

 

Cheers

Tom

Kain_W
Forum Team (Retired)
Forum Team (Retired)

Thanks for the update on this Tomo28,

Do keep us posted on this matter, to clarify is there still an area fault raised?

Regards,

Kain

Hi Kain,

I have nothing to track the area fault unfortunately I was just going off what the engineer told me. The status checker has always said everything was OK even during the issue. But I can confirm I am currently not having any issues and it has been ok for about 48 hours now.