cancel
Showing results for 
Search instead for 
Did you mean: 

Had a power cut and now the router hub doesnt turn on

Freelancer2231
Tuning in

We had a power cut last night and now the router wont turn on. There are no lights or anything. Ive tried it in several plugs in the house and nothing seems to happen. I think it might be dead.

4 REPLIES 4

Client62
Legend

Customer Support are on 150 or 0345 454 1111 from a non-VM phone - log the failure.

Reece_MH
Forum Team (Retired)
Forum Team (Retired)

Hi Freelancer2231 👋

Thanks for posting, and a warm welcome to the Community Forums. 

I'm sorry to hear your Hub is no longer working after experiencing a power cut. I've been unable to locate any details from your Forum account. Have you spoken with our team since posting?

I'm also going to send you a private message, just in case, to gather some more details and assist further. You'll find it in the top-right, white envelope or by tapping your profile picture then "Messages".

Cheers,

Reece - Forum Team


New around here? To find out more about the Community check out our FAQ


Client62
Legend

Try a different fuse in the main plug.

Reece_MH
Forum Team (Retired)
Forum Team (Retired)

Hi Freelancer2231 👋

Thanks for providing me with an update on this via Private Message. I'm glad to hear you've been able to get things resolved. If you do need anything else, feel free to make a new post and one of our team/community will be happy to provide further help.

Cheers,

Reece - Forum Team


New around here? To find out more about the Community check out our FAQ