Showing results for 
Search instead for 
Did you mean: 


Joining in


I've had my hub4 installed last week. Lad who did it checked everything and went saying it's all good. My first action was obviously to change all passwords without even checking WiFi etc, as well as 2.4 and 5 bands name's so all devices can connect to the WiFi hassle free. Unfortunately, the WiFi is not working at all and I'm not even sure if it was because I've changed all the names and passwords immediately. Every time I go to settings tab now and try to enable WiFi, after saving the settings and checking the status - the WiFi is still off, and when I go back to settings page the "disable WiFi" is selected even though I've only just enabled it and saved. I've tried everything multiple times- reboot, factory reset, asking nicely, shouting - but still no joy. I can still access the web via ethernet cable so I've got the connection it's just the WiFi function on the hub that seems to be broken. Been in touch with CS and after 35 min of jibberish talk on the other side, being on hold a while and not understanding my problem by the agent, I've been told to pull out ethernet the cable from my Mac and try accessing so I just hung up because this just broke me...

I believe it's a hardware issue I've got here but no one seems to understand that I can't enable WiFi and no matter how hard I try and despite a confirmation that the settings have been changed and saved, the hub is still not broadcasting any band and WiFi is disabled.

I'm quite limited with time for phone calls due to extensive hours at work and CS is usually closed when I can deal with them so I hope someone here will be able to help me.

If it is indeed a hardware issue how do I request a new hub?



Alessandro Volta

And to think VM made a script for supporting people with wifi they could not help you because you have a faulty hub.



Sometime is is easier to convince the offshore Customer Support team the Hub has totally failed by turning it off prior to calling.


Forum Team
Forum Team

Hello koowal


Sorry to hear of the issues regarding the wireless network, we appreciate the frustration and you raising this via the forums. Welcome to the community.


We have checked the connection and equipment (albeit to the Hub not wirelessly) and everything looks to be within the spec's and ranges we'd expect to see. The speeds look okay but there have been a few disconnection in the last 48 hours.


As you have advised, the changes you have made to the network/frequency names, when you factory reset the Hub did these revert to the original settings and details? if you can let us know as if they did and the issue still persists we can arrange a tech to come out.



Alessandro Volta

Can we just confirm that you have done the reset properly? After holding down the button, you must leave the Hub alone to restart in its own time. Don't disturb it or its power. 

If that doesn't work then follow Client62's advice. 

- jpeg1
My name is NOT Alessandro. That's just a tag Virginmedia sticks on some contributors. Please ignore it.


It's an issue with certain revisions of the firmware.   Factory reset should re-enable WiFi, and the Hub will re-register based on your account settings as before.