Showing results for 
Search instead for 
Did you mean: 

Google Nest won’t connect to heatlink

Joining in

I’ve just changed broadband provider to Virgin and since then my best thermostat has stopped working. I’ve been through all the trouble shooting with google support and tried advice on here but nothing works. I’m left with a useless but expensive piece of kit and have to turn my heating on manually now. Incredibly frustrating. Any advice would be appreciated 


Forum Team
Forum Team

Hi Gepvyt, thanks for the message and welcome to the forums. 

Can you confirm id the thermostat has worked since the connection has been installed?

What error are you getting when connecting? 

Can you do a pin hole reset and connect only the thermostat to see if it connects?

Have you scanned for black spots with the connect app?

Kind regards, Chris. 


Problem sorter

Lots of ways to overcome this issue. What provider were you with before? What hub/router did you have?  Do you still have it?  Things to try include;

  • If you still have the previous router you may be able to put that back in the network to connect via it.  It would need to be configured appropriately.
  • Try using a free wireless analyzer app.  Does that show anything.  Is there a good signal were the Nest and it's heating devices are?
  • Try splitting the bands - different SSID for 2.4 and 5GHz
  • Turn off 5GHz and see if you can connect the devices to 2.4GHz only
  • Try changing channels
  • Any interference from neighbours - on same channels?
  • Use your own router with hub in modem mode
  • Add a wireless access point and connect Nest to that

and so on....

I know a bit about Wi-Fi, Telecoms, and TV as I used to do it for a living but I'm not perfect so don't beat me up... If you make things you make mistakes!

No the thermostat has not worked since I had virgin broadband installed in January, it was fine before when I had shell and I have had the thermostat right in front of the boiler and it won’t connect. There are no black spots, the wifi works fine everywhere in the house

Sorry I don’t really know how to do any of these things, could you explain in more detail please? I’ve only ever plugged in the router and connected it I wouldn’t know how to do the above? Thank you

Forum Team (Retired)
Forum Team (Retired)

Hey Gepvyt, thanks for reaching out on our help forums and welcome to our community recently.

We're sorry to hear you're having issues connecting your smart thermostat since VM services were installed, we'd love to best assist with this.

Firstly, please visit this link here to view how to perform a pin-hole reset and please let us know if once this is done you're able to connect the thermostat only to the Wi Fi.

If not, could you please advise what error you get or is it that your thermostat does not find the network at all? 

Let us know more and we're eager to assist further with this.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Very Insightful Person
Very Insightful Person

If you are not confident in all the changes that @g0akc suggested try the below.

It's a cheap and cheerful wifi extender for 2.4Ghz only that may help. If it doesn't work, simply return it.  Just plug this in somewhere in-between the  Hub and the thermostat.  The adapter connects to the Hub via a simple WPS button press so not technical at all.

TP-Link TL-WA860RE N300 Universal Range Extender with Extra Power Outlet, Broadband/Wi-Fi Extender, ...

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

I have done a pinhole reset, it doesn’t work. I don’t understand how to put the router into modem mode or change the channels as others have suggested so can someone tell me how to do this please? 


Who configured the thermostat to work with the Shell internet router ?
Do you have the thermostat's manuals detailing the steps of that process ?

Forum Team (Retired)
Forum Team (Retired)

Thank you for your reply Gepvyt. 

Information on modem mode and also how to configure your Hub settings can be found here

Please let us know if you have any further questions.