Showing results for 
Search instead for 
Did you mean: 

Firestick can’t connect to wifi

Tuning in

I reset my firestick to factory as it kept saying network error. No internet. I restarted my hub. Did a speed test. All ok but still when o enter my password for my wifi the firestick gets a connection timed out error



Up to speed

Mine wouldn't connect too. I changed my 5ghz security to wpa2 and it connected. It didn't like my wpa3.

I'll try this after work, thanks 🙂

Keep us posted - and if it works - mark @Cawsie's answer 'helpful' so others can find the solution more easily! 🙂

Hub 3 - Modem Mode - TP-Link Archer C7

Very Insightful Person
Very Insightful Person

Correct me if I'm wrong, but I think the only Hub with WPA3 is the Hub 5, so may not work on older versions of the Hub.

As an aside, I use ethernet to connect my Firestick.

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Forum Team
Forum Team

Hi @Suzibloo 

Thanks for posting and welcome to the community.

Sorry to hear of the issues with the Firestick and I hope the advice given has sorted it. As it's a third party device only we wouldn't get involved but I am sure the community will help 🙂

The reason for my reply is that whilst doing a system check, I have identified an SNR issue (signal to noise ratio) in your area. Fault reference is F010616113 and the estimated fix date is the 18th April.

Best wishes.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

Mine is a hub 4. I still can’t get it to connect to my wifi network. It’s at factory settings just now. I chose English then I’ve tried scanning the qr code and entering manually but it just times out. Super frustrating. I can’t get to an area with WAP settings options at all. What can I do??

Hi @Suzibloo

Thanks for coming back to us, as John already alluded to we wouldn't be able to support with the Amazon Firestick issue as it's a third party device. 

However, I have checked your services on our side to see how the SNR outage is coming along, it's estimated to be fixed today by 2:50pm. 

The community will be happy to continue helping with your Firestick issue if it continues after the outage has been resolved.



The WiFi security settings are in the Hub's menu .

Connect at  use the Hubs password from the sticker.

Once in the Hub's menu the navigation is going to be similar to :

Advanced settings >>> Wireless >>> Security

The enable just WPA2-PSK as the Security mode for both 2.4 & 5 Ghz bands.

Be sure to apply the change.

Thanks i'm in there now but I can only choose WPA2-Personal. Which is what it is already set as. There isn't WPA2-PSK available, there is however WPA-WPA2-Personal. Would that help at all?