Showing results for 
Search instead for 
Did you mean: 

EERO Mesh + VM Help

On our wavelength

I have the same problem. Solution has not worked for me. Any other help or suggestions?


[MOD EDIT: Subject title changed for clarity]


Accepted Solutions

I would appreciate your thoughts if this may be the cause. 

I have disabled the Virgin Media Websafe Settings (Virus Safe I left on but I disabled Child Safe). per screenshot. The Eero can now connect. 

Web safe settings available here:
Do you guys want to try to enable and see what happens to your Eero's?

See where this Helpful Answer was posted


On our wavelength

Why does none of this work for me?

I’ve swapped Eeros, I’ve swapped from Hub 4 to Hub 5. I’ve swapped Ethernet cables. 

just cannot get the Eeros to connect in either Router or Modem mode. 

On our wavelength

I am having ongoing issues with virgin media and Eero Pro 6E Mesh.

I’ve swapped Eeros (from Eero Pro to Pro 6E), I’ve swapped from Hub 4 to Hub 5. I’ve swapped Ethernet cables.

I cannot get the Eero Pro 6E to connect when Super Hub 4 and now Super Hub 5 are either in Router or Modem mode.

I do the following:

Set Hub to Modem mode and power off.

Hard Reset the Eero (red light reset), and leave on with Blue Pulsing Light.

Connect Cat 8 cable between Hub ethernet port to Eero WAN port.

Power on Hub and wait 10 minutes.

Try Eero Setup. The Eero Pro 6E will not pick up internet connection and Setup fails.

Doing this with the Eero Pro works.

Eero Customer Support told me to ask VirginMedia to Whitelist the Eero Pro 6E MAC address. Needless to say, VM technical support could not help with that.

Any ideas?

Very Insightful Person
Very Insightful Person

You must get the Eero up and fully working in router mode first, then change it to router mode with WAN port set to DHCP, then follow these:

How to put a VM hub into modem mode:

1) Access your hub on, sign on and put it into modem mode. On the Hub3 the bottom LED will change to magenta, on a Hub4 the LED band will be green. Best done from a wired connection.

2) Turn off the hub and disconnect any Ethernet cables

3) Fully initialise your own router or mesh master unit and make sure the WAN port is set to DHCP

4) Connect your router or mesh master unit to the VM hub with an Ethernet cable, Cat5e or Cat6, any higher specification is a waste of money

5) Turn on the VM hub. 

6) You should now be able to access the internet and the hub will now be on

Note1: this only needs doing once for each new router or VM changes your WAN IP address.

Note2: If you have a Hub4 and your own router is NOT then it’s possible that you can still access the VM hub on

There are 10 types of people: those who understand binary and those who don't and F people out of 10 who do not understand hexadecimal c1a2a285948293859940d9a49385a2

On our wavelength

So took the Eeros to my parents house who also have virgin media. The Eeros setup immediately as they should with no issues. Brough them back here and they won’t get an internet connection again and the gateway goes red.  So what’s the compatibility issue with my vm connection and the Eeros. 

Mesh stuff are a pain it seems put hub in modem mode wait a bit then turn off for 2mins power on mesh and hub wait 5mins and with only the mesh connected unplug replug the Ethernet cable and that should be it.

If you connect the mesh as a router to the hub in router mode and you connect a device to the mesh and this works likely a issue with VM DHCP server which you will not know unless you have networking gear.


Nothing works though. I’ve tried the modem mode sequence. I’ve tried connecting to hub in router mode. Neither work.  But at parents it works first time every time. It’s driving me nuts. 

I just spoke to vm customer support. They’ve suggested I speak with Eero. 

Its possible as unlikely as it seems that the hub 5 DHCP and VM DHCP are some what the same and thats why it don't work.

With the hub in router mode and mesh as router login to your mesh go to WAN IP settings (not the LAN) and put for IP subnet gateway DNS and and see if that works.



 I'm at parents. Set these per your recommendation. Per screenshot. All working fine. I'll go home in a bit and try it. 

Nope. Didn’t work. 
Eero gateway flashes white for a bit then turns Red. 
when I connect to Eero network I get this with no internet connection:


When I connect to Virgin Media WiFi I get an internet connection With get this:


No idea what to try next  - please help community