Showing results for 
Search instead for 
Did you mean: 

Connect app won’t find hub 5

Just joined

My connect app can’t find my hub 5, I have done a hard reset but it’s still not working and I’m connected to my virgin broadband which is working fine any ideas??? 


Accepted Solutions

Trouble shooter

I was pretty sure it had been added going by reading here, the HUB4 finally was.

See where this Helpful Answer was posted


Trouble shooter

I was pretty sure it had been added going by reading here, the HUB4 finally was.

Trouble shooter

I had to totally remove the App and reinstall when the HUB4 was added a few months ago.

Forum Team
Forum Team

Hi Rudy100000, welcome to the community! Thank you for posting. 

Sorry to hear of your difficulties with the connect app and Hub 5. The connect app is now Hub 5 compatible so they should be working together. 

Have you tried deleting and reinstalling the app? Hopefully this has resolved the issue for you! (It may be the case the app just needed the updated software)

You can also find our help page for the connect app here: 

If you are still having issues please let us know and we will offer further support. 

All the best! 


On our wavelength

Hi there,

I’m having the same issue since receiving my Hub5 yesterday and installing it. 

The Connect app can’t find the new hub and also my WiFi pod that you sent me can’t connect to it. 

I’ve tried rebooting my router (hard and soft reboots), rebooting the pod and also uninstalling and reinstalling the iOS app - all to no avail! 

The app and the pod were working fine with my Hub3 but since this ‘upgrade’ I’ve had nothing but trouble! 

Are there any updates on this? I’m sure I can’t be the only customer affected. 

Any help greatly appreciated. 


Hi @wesw82


Thank you for your post and welcome back to our community.


I am sorry to hear that. 


Could you please try manually updating the app?


Open the App Store on your device.
Tap the profile icon in the top right of the screen.
Scroll down to ‘Upcoming automatic updates’, and find the Virgin Media Connect app.
Tap update


Please pop back to us when you can. 

Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

On our wavelength

Hi there,

Thanks for getting back to me. I tried switching the wireless security protocol on the Hub5 from WPA3 back down to WPA2 and now the Pod and app are both working again. 

It may be worth advertising this potential fix more widely as I think a lot of your customers are probably having similar issues with their Pods or their app! 

Thanks again for keeping in touch guys! 

Hello wesw82.

Thank you for this information.

I have passed this onto our Forum Manager now so we can look into making this widely available.

Your time and Knowledge really is appreciated.


Hello we are having the same problems, since having my new hub 5 fitted yesterday. We had no problems with the hub 4

On our wavelength

Have you tried calling VM and asking them to re-link your WiFi Pod(s) to your new Hub5  using the MAC addresses? Level 2 tech support should do this for you.