Showing results for 
Search instead for 
Did you mean: 

Connect app still reading old hub

Joining in

I recently upgraded my hub but the connect app won't let me scan because my home network is still registered to my old hub. Its connected to my new hub and telling me what's connected, just won't let me scan the rooms. I've tried changing it but no luck. 


Very Insightful Person
Very Insightful Person

Hi @Niknak67 

Have you tried clearing the Connect app cache ?

I don't work for Virgin Media.
I'm a Very Insightful Person, I'm here to share knowledge.
Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks
The do's and don'ts.
Keep the community welcoming for all. Please read the FAQ's
The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali

Forum Team
Forum Team

Hey @Niknak67, thanks for reaching out to us and a warm welcome to the Virgin Media forums.

I'm sorry to see the issues with the Connect App not reading the hub correctly 😞
Please can you try the following for me and let me know if it works:

For your Apple device, you can try this: Open Settings > Tap your name > Tap iCloud > Tap Manage Settings > Tap the Connect App > Tap Delete Data.
For your Android device, you can try this: Open settings > Apps > Connect App > Storage > Clear data / Clear cache.

If you are using an Android device can you please ensure you have the following settings enabled:
Location Permissions (Settings > Apps > Virgin Media Connect > Permissions)
Nearby devices (Settings > Google devices & Sharing > Scan for nearby devices).

Also please ensure your device is up to date on it's software and firmware and please try to uninstall the app and re-install the app.
As well can you check if this issue occurs if you download the app on another device?

Let us know how it goes and we can continue on from there.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I did. I read it on here earlier and tried it. No joy. Thanks for replying. 

Hi @Niknak67 thanks for your reply.

Apologies, we currently have a known error with some of the data in our systems that's causing the app to not recognise the Hub in a minority of instances. We're already investigating this as a high priority.

As soon as we have any updates we'll be back in touch.

Many thanks