Showing results for 
Search instead for 
Did you mean: 

Connect app showing wrong SSID

Tuning in

I have just upgraded my Hub from a 3 to a 5 and although the virgin media connect app has picked up my my new router it is still showing my old SSID and I can't home scan as it's asking me to connect to that network. I have done a full reboot of the router and deleted cache and data from the app, deleted the app and rebooted my phone before re installing and logging in but it had not sorted the issue,  has anyone else come accross this? 


Rang Virgin there. Guy said I can manually change ssid and password on connect app but when I try it says this ssid reserved. God knows. It’s working but something ain’t right. 

Tuning in

Hmm just went to access my virgin media app and it updated and now I can see the correct SSID of my router hub 5. Seems they may have fixed the issue. Just a heads up peeps. 

Hi Rodgeu, 

Thanks for coming back to us and updating us to let us know things are updated now. We're sorry to hear there were initially issues with this. 

When you say something's not right, can you expand on this for us? 

Let us know so we can help further. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

My new hub 5 has its own ssid and password. But now when I search for Wi-Fi in my house on any device it shows my old hubs ssid and password. Why would it do this. It doesn’t show my new guns ssid. But it connects to my new hub using my old hubs ssid and password and works fine. Why 

On our wavelength


I too had this issue after upgrading to the Hub5 and changing my SSID via the admin page to Bush. When I then went to the Connect app I sent I'll saw BushGoogle. I cleared cache and data from the app, then logged back in, BushGoogle still showed, so I clicked the option on the home page to Personalise WiFi Network. I then tried to change to Bush but got a message to say the SSID is reserved. What I did next resolved my issue.

From the Personalise WiFi Network screen I performed the below steps

1. Changed the SSID to Bush2 and put in a password.

2. Allowed the change to take place and connected to Bush2.

3. Cleared data and cache from the Connect app.

4. Launched the Connect app and clicked to Personalise WiFi Network and set it to Bush and the password I used when I first setup Bush.

5. Allowed the changes to occur and now the Connect app recognises Bush.




On our wavelength

Sometimes I wonder if anyone responding to is understand the question in the first place!

New hub 5..... Therefore..... New SSID and router password.

Virgin app settings show old hub 3 SSID and password and will not allow this to be changed.

So... Although it recognises the hub 5.... It says it is on the old SSID... When it isn't.

You can see all the devices linked to the hub 5... But when you scan for black spots it insists you link to the correct SSID... The OLD one that your devices cannot link to... Because it no longer exists!

So it raises the question .. Why does Virgin's own app giving customers the ability to make their wifi at home NOT recognise it's own change of SSID... And also... How can I notify virgin that I have WiFi blackspots without being able to use the app to scan the house?!

Has anyone been asked to send screenshots in or anything? I'm not convinced they even know what we're on about... Let alone that it's a 'known' issue or that they are close to fixing it! Lol.

@STCustomer I had eactly the same issue but earlier this week when I logged onto the app it asked me to login again and it finally was able to see my hub 5 router SSID unlike before it was stuck showing the hub3 SSID.  Was about 2 months till I was able to see my hub 5 SSID and be able to show my password from the app. 

Further to this i just checked my app it too has finally updated so I now have the correct network showing, I can scan and can share a guest network with visitors

Been trying the app all day in hope ... And I've just tried it now about 10pm and it came up to ask me to agree to new terms and conditions and..... Now it works! 

Only took 2 months lol. 

Hopefully we will all get this update/bug fix soon and there's will be no more additions to this thread 🙂

It has been great to have somewhere to find others with the same issue. So thanks for all the comments ☺️