Showing results for 
Search instead for 
Did you mean: 

Child Safe switched off but still active

On our wavelength


I have Child Safe turned off but it's still blocking websites.

Can someone investigate please?


Accepted Solutions


Child Safe is a known source of many problems.
For some like you the selected setting in the VM Account is not reflected in the functioning of the VM DNS.
For others the Child Safe On / Off settings fail with errors and they are unable to attempt to apply a change.

Virgin Media's team are as ever silent on mentioning this is a known issue, preferring to waste the customers time in rebooting the Hub when the defect is on the VM back end systems controlling the DNS.

See where this Helpful Answer was posted



Bypass Child Safe

This is a workaround for when Child Safe does not or can not be turned off

Restarting the Hub will not help as it is the VM DNS and not the Hub that is causing the problem.

If you changed the computer's network settings to use any Public DNS does that re-gain access.

Try with OpenDNS using and

I am picking this one as there are instructions here :

For Google Public DNS is would be the same method but and

Forum Team
Forum Team

Hello HydeTDS


Apologies for the web safe issues experienced, we appreciate the confusion this is causing. Were you able to follow the steps in Client62's post? Did they resolve the issue?

If not, let us know and we'll be happy to take a closer look at what's happened.



On our wavelength

I don't want to bypass it. I just want it to honour the switched off state it shows in my account please.

Currently I'm using a VPN to get around this but that too isn't accepted by some sites.

Hi @HydeTDS,

Can you try rebooting the Hub in the first instance as has been advised in this thread? This can sometimes help to push through changes such as this.

Let us know how you get on.


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!

On our wavelength

Rebooting router hasn't done anything. Why can't VM just fix this? It's clearly a bug!

Continuing with VPN for now. But very poor service VM!

My apologies that this has not worked. 

Double check to see if your IP is blocked from these sites rather than the Child safe blocking them to be sure. You can check here for your IP checker. 

Also ensure that your browsers/devices own security is not blocking the sites. 

Here to help 🙂
Virgin Media Forums Agent

On our wavelength

Everything worked the day before joining VM, so it's not my browsers or devices. They also work when roaming on mobile network. So it is VM.

I'm not sure what to do with the IP lookup tool you linked. I'm assuming it'll tell me my IP address as issued by VM? Not sure how that helps me establish if the sites themselves are blocking an IP address issued in the name of VM?

Can someone actually confirm that my account has this switched off in the background please? And that it's not just a case of the dashboard UI showing its switched off to me, when in fact it's not triggered the configuration behind the scenes?

Alessandro Volta

VM implemented Child Safe on/off is bad and they will not fix it but at least you can change the DNS on your device.


On our wavelength

I don't know what the issue really is. This switch worked when I last joined VM some two & half years ago with a recent 6 month gap due to a house move.