Showing results for 
Search instead for 
Did you mean: 

Channel 4 All4 Geoblock continuing on Samsung TV

Tuning in


I've been seeing Geoblock 4001 Error codes on my Samsung TV for at least the last two weeks and this is still happening as at 03.08.2022.

I see this happen when I try to watch the "Mission Impossible" and "Watchmen" fillms on the All4 streaming service.

The TV is running on a NAT'ed IP address behind my Business Broadband router.

Given the other messages appearing here, I strongly suspect this is down to how the All4 server that the TV is connecting to is determining the physical location of the VM public static IP address allocated to the connection.

Please can VM Tech Support advise as to how their IP Addresses are mapped to physical location?

It might well be down to metadata registered by VM with the InterNIC.






Forum Team
Forum Team

Hi @jdl666 thanks for posting and welcome back to our community.

Please can you clarify if you're a Virgin Media Business, customer?  If so, we'd ask that you contact them directly on 0800 052 0800?  All their contact methods can be found here.  However, if you are indeed a residential customer, please do get back to us and we'll be happy to take a look for you.


Thanks, I have now contacted Business support via your online support form.

Did you get anywhere?

I was rather hoping that the clocks going back would have fixed this, given the issue started for me around the time when they went forward but no such luck 😕

No, I didn't get anywhere.

I've sent technical queries to both VM and the All4 App Technical Support team but have since had no further response.

What I suspect is happening is that the All4 server application on Channel 4 is doing some form of lookup of the VM client IP Address used by my Samsung TV, and the lookup method they are using is then producing a result that says I'm outside the UK.

However, I'm not outside the UK *and* I'm not using a VPN.

My IP addresses are in the range[REMOVED]


I suspect that it's:

*** either ***

the lookup mechanism that Channel's All4 server is using either has incorrect entries for that range, or simply failing for those addresses and assuming a default of "not in the UK",

*** or ***

if VM are responsible for registering and maintaining the [IP Address => Location] data, then VM have set it up incorrectly.


It was all working fine last year, but something has changed, and no-one at either VM or Channel 4 are taking responsibility for diagnosing the issue at their end and sorting it out.

I'd appreciate it if someone in network technical support at VM could now get round to lookingf further into this, and liaise with the Channel 4 All4 Team to get it sorted, because it's all been going on for too long without a solution.

[MOD EDIT: Personal and private information has been removed from this post. Please do not post personal or private information in your public posts. Please review the Forum Guidelines]


I've done some more digging around early this morning and come up with some more observations.

I tried creating a new All4 account, then using the new account:

- on my original Samsung TV, I get the same GEOBLOCK message.
- on my 2nd Samsung TV, I also get the same GEOBLOCK message.

If I change the Public Static IP Address to another address in my IP block, I get the same GEOBLOCK message.

- However, if I access All4 via a FireFox Web Browser on my PC with either of the two public Static IP addresses, then it shows the All4 content fine.

So it looks like an issue with the Channel 4 All4 App installed on the Samsung TVs, rather than a blanket GEOBLOCK on the IP addresses at the VM end.

It may be that the TVs' All4 app is performing a GEOBLOCK query in a different way, so it could still be a VM IP=>Location lookup issue, unless the Channel4 All4 Server is maintaining it's own GEOBLOCK data locally.

I guess one last thing to try is to see if I can login to All4 on the TV via the TV's browser rather than going through the All4 App.










The TV's web browser doesn't support viewing All4 via the Web.


Hi jdl666, thanks for getting back to us with an update.

Sorry to hear you're still unable to view All4 on your TV set.  Do you have any other smart TVs in the house that have the app?  Or indeed some form of smart set top box you can test this on?  If you attempt watch All4 on a device like a tablet or PC/Laptop, is that being blocked?  If you attempt to watch via mobile web, on a smartphone for example, do you still get the same error message?



Hi Lee,

As discussed above, I have two different Samsung TV's and both are unable to view All4 because of the GEOBLOCK message.

I can view All4 in a Firefox Web Browser on my Windows 7 PC - no error message is displayed in that case.

I suspect that the All4 Server which the All4 TV app is connecting to is performing some form of lookup of Location against the IP address which is not triggered when using the FireFox Web Browser, and the location information is then wrong.

If VM are maintaining and registering the Location information for the IP address in some public Internet Table, then it needs to be corrected.

It was working fine earlier in the year. I suspect it may have something to do with the updated version of the All4 App software (and presumably the All4 Server software it talks to) which came out this year.

It would be good if the Tech Teams at VM and the Channel4 All4 Server teams could liaise together to resolve this.









Hi jdl666, thanks for the message and sorry to hear that you are having issues with this. 

Can you switch off the box for five minutes and switch it back on to see if anything changes?

Do you get the same issue when viewing from a laptop/ tablet?

Kind regards, Chris.