Showing results for 
Search instead for 
Did you mean: 

Can't log into 3 Hub

Joining in

Hi Virgin Community, 

I have the hub 3, I need to log into my hub and change the advanced setting due to WIFI issues, some of my devises are having problems connecting.

I have tried logging in with the smaller password on the back, which is not working, I have also tried the default password I looked up online. I have reset my device multiple times, 5mins 10mins ect.

I called up Virgin support, only to be told its a connection issues, I don't think they understood my problem. 






The "Settings password" from the label on the bottom of the Hub 3 should be the required password,
in our case it is all numbers.

Exactly what is the error message you are seeing ?

e.g. using the wrong password our Hub 3 gives ...



Yes that's the error I keep seeing,

If after use of the rear Reset button our Hub 3 rejected the Setup password, we would consider the Hub to be defective.

I have used the reset button and I am still having the same issue, I believe the router
to be defective.

Forum Team (Retired)
Forum Team (Retired)

Hi CJ101, thank you for posting on our help forum and sorry to see you've had trouble logging into your hub 3 settings page recently.

Since you've last posted here on Wednesday, have you managed to access the settings and make changes or received some help from our phone agents in the meantime?
If you're still experiencing issues with logging in, please follow the below steps on your pc/laptop browser:

Check you’re connected to the Hub before following these steps.

  1. Enter into the address bar of your browser. This is the Virgin Media modem mode IP address.
  2. Select Next and enter the Hub settings password which is on the base of the Hub. This is different from your WiFi password.

Could you please also try doing this on a different browser and/or device to see if it works there?

Please, let us know if the above has been tested and failed after a pin hole reset has been performed too.
We're eager to assist further if needed.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi Adri_G

Thank you for posting, I have tried the factory reset, where I pressed the pin hole and I still can't login.
not sure what to do next.

Hi @CJ101 👋,

Thanks for coming back to us. I am sorry to hear a pin hole reset made no difference. 

Could you clarify if you have tried the steps advised by Adri in a different browser?

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I have double checked, I needed to open the address in a different web browsers. Thank you for your help.