cancel
Showing results for 
Search instead for 
Did you mean: 

Can’t access GTA online or Rockstar Social Club website

SamirM246
Tuning in

Good afternoon, hope everyone is well. I have been unable to access GTA online on my ps4 and ps5 or Rockstar Social Club on all devices for the past few days. I keep getting error messages. I have tried on my mobile hotspot and it works then. I also tried on my grandmothers wifi, who’s also on virgin and it worked on there too. I have no idea what the issue is and how to fix. I have tried changing the DNS but no luck. Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions

Hey @SamirM246

Thanks for getting back to us, we're glad you managed to get this issue sorted, we do have our own WIFI Pod system which you can find more information about here.

If you have any further questions don't hesitate to reach out we will help as much as we can.

Thanks, Joe

See where this Helpful Answer was posted

54 REPLIES 54

David_Bn
Forum Team
Forum Team

Thanks for your post on our Community Forums @SamirM246, and a very warm welcome to you!

Sorry to hear of the issues with the services when trying to play GTA and Rockstar Social Club on your PS4 and PS5.

Can you confirm if this is still on going, or have you since found a solution to this issue?

Have you reported this to Sony or the manufacturers of the games to see if this is a issue they have experienced with ourselves or other providers, to see if a workaround is available?

Kindest regards,

David_Bn

Hi David thank you for your response. The issue is still ongoing. I have contacted Sony and they have said it will be an ISP issue and nothing they can do. The social club issue is on the internet on all devices and not on ps4 and ps5. Kind regards, Samir 

Thanks for getting back to us Samir 🙂

Can you confirm what the error is that you're getting?

Have you ever had this issue in the past?

Alex_Rm

Hi. Thank you for responding. The error is “rockstar services are unavailable right now” and this happens only on my Wi-Fi. When I use mobile hotspot it works. I also can’t access the rockstar social club website. I have never had this error before 

Hi. I have reported this issue to rockstar and Sony and they have both stated it is an ISP issue. And yes it is ongoing

Hi SamirM246,

Thanks for confirming that. Is it just the GTA/Rockstar servers that you are having problems connecting to? Do you have any form of Child/Web Safe active on your service? You can check this in your My Virgin Media, and also disable it from there if it is active. If it is active, and you've disabled this, please reboot your Hub and this should allow the settings to update.

You've mentioned changing your DNS, can you please double-check whether the DNS has any form of "safety" features such as their own version of Web Safe? 

The Child/Web Safe feature can, and does, block access to specific websites that are identified to be inappropriate for children, plus additional custom settings such as Social Media and Gaming.

Thanks, 

Reece - Forum Team


New around here? To find out more about the Community check out our FAQ


Hi Reece thank you for the response. I just checked this morning and saw it is now working. It seems to have solved itself. Thank you all for your help. 

regard, Samir 

It has happened again unfortunately and I’m getting quite annoyed. I don’t understand why this has happened.

Hi SamirM246, 

Thank you for your reply, and I am sorry you are still having issues. I have checked and I can access Rockstar Games Social Cub on my Virgin Media connection. Do you have any images of this? Is this the only site you are having issues accessing? 

Are you able to get online on GTA 🎮?

Let us know.

Zoie