cancel
Showing results for 
Search instead for 
Did you mean: 

Apple TV App on LG Smart TV

mwhatleyarch
Joining in

I swapped to Virgin Media broadband in April and ever since swapping, the Apple TV app on my LG TV will only play shows when limited to SD playback. When trying to play in HD the show starts streaming and I get around 20-30 seconds of viewing before it then states 'Video unavailable'.

All other streaming services work fine on the TV and have tried resetting the app, reinstalling it etc but still no result. It I have seen mention that it might be something to do with a problem between VM and the Apple relay but can't seem to find a resolution.

Any help would be great!

11 REPLIES 11

Adduxi
Very Insightful Person
Very Insightful Person

Is this wired or WiFi ?  If WiFi try a temp cable connection to the Hub and see if that helps?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

It was via WiFi but have swapped to a wired connection and still having the same issue.

I just can't figure out why every other streaming service works at full HD/4K but Apple TV only works in SD.

Hi @mwhatleyarch 👋 Thank you for your post and welcome to the Virgin Media Community 😀

We're sorry to hear about the problem you're experiencing 😔

Do you have the app installed on any other devices? If so, is it the same problem on those?

Regards,
Daniel

Hi Dan,

No problems. I tried it on the Chromecast last night on our TV upstairs over WiFi and that worked in full HD so must be something between Virgin Media and the LG TV as it only started once we swapped that the problem started.

Thanks.

Matt

Client62
Legend

Does the Apple TV app on the LG TV have a network diagnostic option to test the quality of its connection ?

Are we missing some key information like, WI-Fi repeaters or Power Line extenders or some other network gizmo like a Router are involved in this puzzle ?

In the Virgin Media account, Child Safe has been seen to play havoc with some video playback platforms, do you have Child Safe Disabled ?

VM Web Safe settings for Hubs in Router mode

Login to the Virgin Media online account at : https://www.virginmedia.com/my-virgin-media

Then visit : Account Settings >>> Online Security

Set Virus Safe to On   ( On is normally OK )  
Set Child Safe to OFF ( this is the option that is blocking most content )


Thanks for coming back to me mwhatleyarch, are you able to follow the advice from Client62 to see if that will resolve your issues?

Kind Regards,

Steven_L

mwhatleyarch
Joining in

Thanks Client62 and Steven_L. First in response to the above...

I have tried the troubleshooting within the app which runs a kind of diagnostic and it says there is no issue with internet or streaming etc.

The TV is plugged straight into the Hub 3 on it's basic settings which has Child afe set to OFF and have tried the Virus Safe both ON and OFF and it makes no difference.

I have done some investigating and I actually think it's more to do with Apple TV and the TV as programmes which were available before June this year play fine in full HD, whereas those added later do not work. For example, High Desert, the first episode which was uploaded on 17th May 2023 seems to play fine (I haven't watched the full episode but it didn't cut out). Whereas the last episode, added on 21st June 2023, got 20 seconds in and came up with the same Video Unavailable message.

This might actually make it more complicated though rather than helping at all! It makes me wonder whether it is now an issue between the Apple TV app and the TV rather than Virgin Media? Unless it is just the new videos VM doesn't like. Either way, I think I'm more confused!

This is not sounding like a VM issue. 
Does Apple TV app on another device ( computer / tablet ) have the same issues ?

Roger_Gooner
Alessandro Volta

Have you contacted LG or another forum for help?

--
Hub 5, TP-Link TL-SG108S 8-port gigabit switch, 360
My Broadband Ping - Roger's VM hub 5 broadband connection