Showing results for 
Search instead for 
Did you mean: 

cannot register

On our wavelength


I am new Virgin Media customer and I am trying to register on MyVirginMedia.

I am not able to do this as whatever I try, I am getting the error "You can't use that password. Please choose another" when entering a password for my account.

I have tried both through a few browsers: Firefox, Chrome, Edge and Epic  and also through the MyVirginMedia app on Android and get the same error whatever.

It says that "All password requirements met " but won't allow me to create a password whatever I try.  I can see from other Forum posts that this seems to be a common issue - please can someone help me solve this so can access my account?

I have tried multiple diffrent passwords and still same issue 


Forum Team
Forum Team

Hi iand,

Thanks for posting and sorry to hear you're having some issues creating an online account. 

Can you confirm if you've usedNo special characters, only letters and numbers, MUST begin with a letter, try keeping it between 8-10 characters?


On our wavelength

says weak 8 to 10 charecters using only letters and numbers tried bettween 8 to 11says weak 8 to 10 charecters using only letters and numbers tried bettween 8 to 11SAYS WEAK BETWEEN 8 TO 12 CHARECTERS AND ERROR YOU CANT USE THIS PASSWORD


On our wavelength

Screenshot 2023-01-15 194923.png

Very Insightful Person
Very Insightful Person

The current password criteria are:

8 to 64 characters
can only contain alphanumerical characters (a-z, A-Z, 0-9) and the following additional characters !@#&*_
must contains at least one letter and numerical character.

There have been reports of passwords being accepted even though the on screen message says otherwise.


I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media, I'm a VM customer. There are no guarantees that my advice will work. Please read the FAQs
Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

On our wavelength

yes not used any special charecters started with a capital letter also tried without  im guessing my password could be any of the 50 + i tried to use but im guessing it didnt accept any as cannot reset pasword via asking for an email to do so not registered  seems there password checks are impossible to pass

Have you tried to access using the password you're trying to change it to iand? As Graham_A has mentioned, there have been reports of customers changing the password and getting the error when it has actually updated.


Can you see if it has actually updated?



On our wavelength

no it didnt   Screenshot 2023-01-16 085936.pngScreenshot 2023-01-16 090325.png

On our wavelength

seems to be a problem with gmail email accounts i used a difrent email and it registered straight away

Hey iand, thank you for reaching out and letting me know this.

I will definitely pass this feedback on. Thanks 

Matt - Forum Team

New around here?