Showing results for 
Search instead for 
Did you mean: 

Unable to turn off web safe

Joining in

I've been trying for many days to turn off web safe but it is impossible, when I click on manage web settings I'm taken to a page that never loads, just showing the virgin media icon looping.

Is there another alternative to turn off web safe? I've tried with different browsers, in incognito mode, tried with my phone, etc... But it does not work, the user experience is terrible.


Forum Team (Retired)
Forum Team (Retired)

Hi ansank, thank you for joining our help forum page and for your first post here.
A warm welcome to the VM community, nice to have you on board. 🙂

We're sorry to see you're getting errors when trying to switch off your web-safe feature for the broadband at home, we're eager to lend a hand with that. 🙂

In order to enable me to help further with this, I will shortly send you a private message here.

Please, check the top right-hand side of our page to find a white envelope.
Click on this and you'll see my message.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi there. I am having this exact same problem. Can I also have some help please? Thank you.

Joining in

Hello, I am having this problem too. Tried every browser, device, incognito mode etc. Any help appreciated