Showing results for 
Search instead for 
Did you mean: 

Unable to register account

Tuning in

I have recently joined Virgin broadband and when I try to register a Virgin media account, half the time when I type in my email (which I’ve received emails welcoming me as a new customer so it is correct) it comes with an error saying Code: DEF01 and that I’m unable to proceed, the other half of the time it says that I’ve left Virgin and so as I’m no longer a customer I can’t register an account! 
This happens both going through the app and on the web, I have tried using different browsers.

what can I do to solve this issue? Thankyou. 


Forum Team
Forum Team

Hey @nadiak,

Welcome to our Community Forums and thanks for your post 🙂

I'm really sorry to hear you're having issues when registering with My Virgin Media. Are you using the same email address that you used for an account previously? Have your services been installed? If they haven't, then you wont be able to sign up for My Virgin Media just yet. You'll need to have your services installed and activated before accessing the My Virgin Media platform.

If you have been installed, can you please ensure that the password you're using meets the following criteria:

- Between 8-10 characters.
- Must start with a letter.
- Must contain at least one number.
- No special characters.

Can you also let me know which link you are using when trying to register? Can you please try either this link or this link and let me know how you get on?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Forum Team
Forum Team

Hi Nadia,

I'm really sorry you're still having issues with this after our IT Team came back with a fix. I've asked for the ticket to be reopened. They will investigate further into why you're still unable to access the My Virgin Media platform. Once I've had an update, I'll reach back out via PMs 🙂


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ

Hello, this issue is still ongoing and it’s a long time since this was initially reported please can I get an update? 

Thank you for the update @nadiak,

Sorry to hear that the issue is ongoing. Just to confirm, have you ever had an account with ur prior under the same email? Also, have you tried clearing cookies and cache in your web browser to see if the issue persists? 

Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Yes, I confirm that I had an account with the same email address about 6 years ago and that the problem persists even if I switch browsers and even if I clear the caches cookies and data. 

previously someone referred the issue to your IT department who said they’d fixed the problem, however I replied saying that it had not been fixed. That was two weeks ago, the person following up on that ticket then stopped replying to me. 

Hi Nadia, thank you for coming back to us with an update!

Sincerest apologies that this has still not been resolved for you. I will send you a PM to confirm a few details so I can chase this for you, and offer further support. 

You will find the PM in the top right corner of the page in your Inbox. 

We can then return to the public thread with an update when possible. 

All the best!