Showing results for 
Search instead for 
Did you mean: 

My virgin media - cannot sign in

Joining in

I have registered my account but I am unable to actually manage my account. On the app it shows my bill but I can not change any details if I needed too. I can't access my account because when it sends me to the my virgin media website and sign it, it says "opps, something is wrong our end try again" it's been like that for a month. When I registered my account I received an email to verify my email address and it came up with an error. I try to receive a new verification link and it doesn't send it to my email(yes I've looked in the junk folder). It's like my account is half set up and I can't actually use the service properly. I tried calling customer service and to be Frank, they were useless. 



[MOD EDIT: Subject title changed for clarity]


Forum Team
Forum Team

Hi there @Dbennett26, welcome to our forum and thanks for your post.

I'm sorry to see that you are having issues updating your details on your online account. So we can assist with this further, can you please try doing this on an alternative browser or device to see if you get the same issue?

Also, I would recommend clearing the cache and cookies to see if this helps resolve the issue. If you need any further help after trying this, let us know and we will be happy to help further.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

Hello Nathan

I have tried other browsers and experience the same issue and I have also tried clearing the cache and cookies and still have the same issue.

Forum Team (Retired)
Forum Team (Retired)

Hi @Dbennett26,

Thank you for coming back to us about your issue and I'm sorry to hear that this problem is ongoing.

Have you tried to access your online account via the App? Are you getting the same error there? Have you tried to click on Forgotten Password to reset it to see if this can assist?

Keep us updated. 🙂

Thank you.

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs