Showing results for 
Search instead for 
Did you mean: 

Cannot set up My Virgin Media Account

Joining in

I've seen several threads on this and it seems there is no published answer.
I'm trying to set up My Virgin Media account and when I get to the password setting phase I get the message You Cannot Use That Password.

I've tried on 3 different laptops and on the Apple app, and with 2 different email addresses. All the same result.

I don't see any solution being offered on any of the iterative threads on this over several months.

So how do I access my Virgin account? Can a Virgin person respond with a solution please?


Forum Team
Forum Team

Morning @Robw1704

Thanks for posting and welcome back to the community.

My colleague did reply to you yesterday, putting;

Can you please ensure you are following ALL of the below criteria when choosing a password.

Between 8-64 characters.
Must start with a letter.
Contain at least one number.
Contains only one of these special characters: !@~&*_
If you are 100% certain that the above requirements are all being met then can you try some different password variations? This is because we've had reports of customers being able to proceed when doing this and it's mainly because some choices are too guessable to be allowed.

You should also try registering through the website as opposed to the app to see if this helps. 

Best wishes,

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

I work in IT.
I followed all the password rules. 
I tried on the web site on 3 different laptops so there is definitely no caching errors going on.
I tried on the app. 
Same result each time.
This time I used password John_GS_17-11-2022 just for devilment.
Guess what? It didn't work. "You can't use that password. Please choose another."
I then thought perhaps it's exact as in "only use ONE of the selected special characters" and no more.
So I tried JohnGS_17112022AA
Exactly the same error.

Hi Rob,

Thanks for reaching back out, please try something personal to you, when trying just swap some of the letters for numbers such as o for 0 or e for 3, don't forget to add at least 1 special character such as @.



I've tried varying combinations of passwords, both scrambled and human readable.
All exactly the same result.
I'm an IT Manager - passwords are supposed to protect the system they give access to. This is taking it to a new level.
I only hope that once this is resolved, it's not an expiring password and I have to repeat the process every 1 or 3 months.
This is not a very good user experience that Virgin Media is offering is it?


I've even tried these in Incognito windows on Chrome.
Alas, the same result each time.

Hi Robw1704,

Thank you for trying, can I ask, have your services already been installed?



Hi Paul,

Not yet - scheduled for next week. Direct Debit set up. And plenty of emails telling me to get the app and saying "If you haven't already registered...." to download and register.
The error message doesn't say "You can't register yet." It clearly says "You can't use that password. Please choose another one."

Regards... Rob

Thanks for your reply @Robw1704, this should work for you before the service has been installed.

As you are still not having any luck with this it would be best to raise this to our IT team. To do this, I will send you a PM to confirm your details.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules