Showing results for 
Search instead for 
Did you mean: 

Can't register new account

Joining in

When trying to set a password the interface rejects every password I enter, despite it saying the requirements have been met. I see several others on these boards have had the same issue around the summer time, can you please fix this for me as it's extremely frustrating.l and not a good start to things. Thanks 


Forum Team
Forum Team

Hi @FDorrian87, thanks for reaching out to us and a warm welcome to the Virgin Media forums.

I'm sorry to hear about the issues with the password not being accepted.
May I ask if you've cleared cache and cookies? Or tried another web browser / device?
And has your Virgin Media services itself been installed? Because if they are pending install, then you won't be able to make a MyVM until the installation has completed.

Let us know.

Kind regards,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Yes all of the above have been tried and my service has been set up and installed as of yesterday.

Thanks for coming back to us @FDorrian87, check out the purple envelope in the top right hand corner for a private message from me, and I'll look into this further for you - which may result in my need to raise an IT ticket.

Kindest regards,


Just on the offchance anyone from.the forum team is lurking, this issue is till happening, I would appreciate someone fixing it please


Mate it ain't getting fixed here, they just string u along...