Showing results for 
Search instead for 
Did you mean: 

Can't add TV & Broadband to my My Virgin Media app account

Tuning in

Hi all

I'm a customer of both mobile and TV/Broadband/Phone, and have just downloaded the My Virgin Media app. I began the log in for my mobile phone account, and have had no problems, but when I come to 'add media account', and attempt to sign in using my email address I get an error 'Oops - the page has timed out. Looks like this session has expired. To continue close this page and start again'. This happens each time I try, and also happens when trying to connect with the Virgin Media Connect app. 

I'm using an iPhone 11, running iOS 16.3.1 and connected to my home wifi (although the same error occurs if connected to mobile data). 

I generally run via a VPN, but I get the same error whether the VPN is on or off. 

Any help will be greatly appreciated - many thanks


Forum Team
Forum Team

Hi Amo78, 

Thanks for taking the time to contact us via the Community. It's lovely having you on board with us in the Forums.

We're sorry to hear you're having an issue when trying to log in to both the Media and Mobile side of things. 

For the My VM app, can you try deleting the app, reinstalling it and then logging in to the Media side before the mobile side? 

With accessing both the mobile and broadband features on the Connect App, this is because to connect to your Hub you need to be on Wi-Fi, but to see mobile, you need to be on mobile data. This is a limitation that we will fix in a future release, however, until then, once you've logged in on mobile you can turn your Wi-Fi back on and you should be able to connect to the Hub too.

Keep us posted on how things go. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Hi Kath

Many thanks for your reply. I have deleted the app and reinstalled, but am still getting the same message when I try to log in to the media side. It appears as soon as I have filled in my email address and hit continue on the 'Sign in to My Virgin Media page' ( 

With regard to the connect app, I also get the same message when trying to connect to the hub via the media logon. The mobile aspect seems to work fine, but on both apps it won't let me past the sign on screen.

Many thanks

Hi Amo78, 

Thanks for coming back to us on this one. 

It sounds as though the issue is with the Media account in that case. Can you try following the 'forgotten password' link on My VM instead of logging in and try resetting the password. Make sure you choose a password that you haven't used before.

If you're still having an issue after this, pop back and let us know. 

Many thanks, 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs