Showing results for 
Search instead for 
Did you mean: 

Account now active and kit installed....still cant register for my virgin

Tuning in

As title was previously told to wait till account was installed, but I still can't get past creating a password...tried all recommend password guidelines but nothing accepted...


I'm a new customer on a top package but I can't see any billing...


Forum Team
Forum Team

Hi AmarA3, 

Thank you for your post 🙂 

I am so sorry to hear you are having issues registering your account, can you confirm for me if you have done the following:

  • Cleared all cookies/cache
  • Tried a different browser
  • Tried a different device

Do you have a screenshot of the error? ( all personal info blacked out) 

Ive tried on multiple devices and cleared cookies...its the same issue as many others are having and I reported  weeks ago but was asked to wait till services are installed so here I am..

I use my email and then it asks to create a password, i meet requirements, but still it shows in red you cant use that password.


Sorry to hear the issue persists @AmarA3.

I can see you are currently in private messages with a member of our team regarding this. They will do their best to look into this issue for you and provide a resolution.


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Actually I am still waiting, please can this be picked up once and for all ?

I've been trying to resolve this for a month, private messages seems to have stopped dealing with this, I am on the top package as a new customer yet I cant log in or see my bills or access my account.

I have tried all the suggestion on these forums and now just need this resolving as its clearly not anything from my end..