cancel
Showing results for 
Search instead for 
Did you mean: 

Virgin Mobile Website login

Nicoll
Joining in

Hi 

 

When ever I try to log on to my virgin Mobile website using my windows Laptop the Blue circle comes up and doesn't load the page on.

 

Once I enter my email and password the page doesn't want to load. My Windows laptop Is running Windows chrome.

 

Please help me on this.

 

Thanks Matt

 

 

 

11 REPLIES 11

Travis_M
Forum Team
Forum Team

Hi @Nicoll

 

Thanks for posting on our community forum and sorry to hear about the issues with the Virgin Website.

 

Are you able to try a different web browser for us and keep us updated with how you get on please?

 

Regards

Travis_M
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Hi I have tried chrome and Microsoft Edge and neither of them works.

 

 

Hey Nicoll, thank you for confirming this for me.

Do any errors pop up or is it literally just a white loading screen you see?

Has it ever worked for you at all before?

Is your browser and laptop fully updated? 

I would also try clearing the cache. Thanks 

Matt - Forum Team


New around here?

Hi 

 

There is no error messages appearing just a white blank Screen.

 

Yes I have tried clearing the cache but will try again.

 

Matt

Hey Nicoll, please try this again.

Is this happening to any other websites, or just the Virgin one? Thanks 

Matt - Forum Team


New around here?

I have tried it again and still doesn't work 

It is just the Virgin  website that doesn't work.

 

Matt

 

 

 

Hey Nicoll, thank you for letting me know this.

We aren't aware of any issues with people getting on our website, by any chance you don't have pop-ups blocked do you?

Also, does this site load for you when you use mobile data for example? Thanks 

Matt - Forum Team


New around here?

Hi 

 

Yes it works when I use my mobile data on my phone.

I want to log in via my Windows Laptop so I can download my bill each month.

I will check my popups. Any other suggestions would be truly helpful.

 

Thanks 

 

Matt

Hey Nicoll, thank you for confirming this.

Does it let you actually go on our website but when you go to login in to your online account, is this where the loading screen comes in place?

Please try and the pops and turn off any ad blocker you may have on also. Thanks 

Matt - Forum Team


New around here?