cancel
Showing results for 
Search instead for 
Did you mean: 

O2 Priority APP doesn’t link with virgin media

AndrewT1
Tuning in

I’ve just signed up with the o2 priority tickets app and it’s not working properly. I’m hoping to get some tickets this morning at 9am presale. 

Have tried uninstalling and reinstalling the app, but no joy.

 

I’ve read previous comments over the last few weeks stating that the app is frustrating and engineers are working on it etc etc 🤥  my suggestion is either have an app which works…or scrap the entire thing altogether ( unless 02 and Virgin media wish to get bad publicity and lose potential customers).

31 REPLIES 31

Exactly the same here!

iPhone XR , 16.1.1 operating system iOS.

latest app version 

 

yes indeed have registered.

Ok I have my issue resolved.

 

I read an FAQ somewhere that said to click the forgot password link if having trouble signing in.  This leads you to effectively change your password via a link that you receive in an email.

From what I understand this means that the password change was required or by using the link sent to your email you effectively verify the email address.  Whatever the reason I was then able to sign in.

PS you have to actually ensure its logged out first either by clearing cookies or if you can see the option to log out then can use that.

Ok thanks for this advice…fingers crossed it will work for the next time I’m after priority tickets! 🥸 🤞

Hi there @VipT, thanks for the update. I'm glad to see this is now resolved for you.

Thank you also for posting your resolution to help any users that may be experiencing this issue. If you need any further help, please let us know. We will be happy to assist.

Regards

Nathan

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


Hello,

I'm having the same trouble as VipT. I have tried resetting my virgin media password and that didn't work. Is there something you need to do in the background to get sign in with virgin media to work on o2 priority?

Every time I sign in with the iOS Priority app using my Virgin Media ID and password it crashes - looks like there is a bug that needs resolving.

Hello banhamm.

Thanks for bringing this to our attention.

Can we please ask if you are running the latest IOS?

Does removing and readding the App wotk at all?

Gareth_L

Hi Gareth

i am running an iOS 16.2 public beta which may be having an effect. However I have previously been logged in via VM login ID with no issues. 

Thanks banhamm.

Did you back u your device to try reverting back to the previous IOS.

Just wondering if it is possible to try that then log into the App?

Gareth_L