Menu
Reply
dave10011
  • 7
  • 0
  • 0
Joining in
657 Views
Message 1 of 12
Flag for a moderator

IMEI not recognised

Hi, I have the same problem -Dave

0 Kudos
Reply
Laurie_C
  • 978
  • 29
  • 91
Forum Team (Retired)
Forum Team (Retired)
633 Views
Message 2 of 12
Flag for a moderator

Re: IMEI not recognised

Hi dave10011,

 

Thanks for getting in touch. I'm really sorry that you're also having this issue.

 

Could you please confirm if this is for Trade Up/Trade In? Could you also confirm if you are taking the IMEI off the phone directly?

 

Kind regards,

Laurie

Laurie_C
Forum Team
0 Kudos
Reply
dave10011
  • 7
  • 0
  • 0
Joining in
601 Views
Message 3 of 12
Flag for a moderator

Re: IMEI not recognised

Hi Laurie,
This a new Virgin Mobile SIM I was offered as part of package for my new Broadband contract.
I put it in my BLU Lifemark phone, which was the phone I had before my current Samsung A20e, to use as a hotspot.
The IMEI came from a label printed inside the BLU phone.
Later I tried the SIM as the 2nd SIM in my Galaxy and the data worked straight away, so I assume it's either the Android version is too old or it's not compatible with the BLU phone - although I could receive phone calls and SMS's using it.
0 Kudos
Reply
Martin_N
  • 7.58K
  • 323
  • 474
Forum Team
Forum Team
593 Views
Message 4 of 12
Flag for a moderator

Re: IMEI not recognised

Thank you for that information dave10011.

 

I just wish to confirm what is the exact issue you're having? And what is it you need assistance with?

 

^Martin

0 Kudos
Reply
dave10011
  • 7
  • 0
  • 0
Joining in
588 Views
Message 5 of 12
Flag for a moderator

Re: IMEI not recognised

I placed my new Virgin SIM into my BLU Lifemark phone and was trying to access roaming data through it. Once it had connected I could receive phone calls to it and SMS messages but no data.
I tried following suggestions on your website about turning off roaming data - leaving for 24 hours - turning on again and waiting another 24 hours, but still no data.
I tried finding the IMEI number for my BLU mobile using SMS *#06# but nothing was returned - so I removed the battery and got the IMEI number from the sticker under the battery.

I fitted the SIM into the 2nd slot on my newer Samsung Galaxy A20e mobile and roaming data happened almost immediately.
I wanted to use the SIM in the BLU mobile so that it would act as a WiFi hotspot, which I could leave indoors whilst using my Samsung away from the home.
0 Kudos
Reply
Tom_F
  • 4.22K
  • 250
  • 536
Forum Team (Retired)
Forum Team (Retired)
578 Views
Message 6 of 12
Flag for a moderator

Re: IMEI not recognised

Thanks for clarifying Dave, sorry for any confusion I'm just not sure where the IMEI would come into that - it's totally separate from your mobile data.

 

As the data works fine in another handset it would suggest to me the problem lies with the BLU handset or it's settings. Have you been able to go through the BLU handset's settings and make sure mobile data is enabled?
 

Tom

0 Kudos
Reply
dave10011
  • 7
  • 0
  • 0
Joining in
555 Views
Message 7 of 12
Flag for a moderator

Re: IMEI not recognised

Hi Tom,
As far as I can tell I had set the BLU phone for mobile data.

I was following the help guide at
https://www.virginmedia.com/help/virgin-mobile-roaming-troubleshooting#data

which led me to
https://mobile.virginmedia.com/ecare/plandeviceoverview

selected "Need help with your mobile device?" = https://devicesupport.virginmedia.com/

as my phone was not listed it told me to go to
https://devicesupport.virginmedia.com/customer/imeilookup/

As my phone was not listed, it asked for the IMEI number of the phone - I tried the *#06# method but got no answer back. I found the IMEI under the battery and entered it, which got result...

Sorry, we don't recognise the IMEI you provided.
Please double check and press Back to return to the device picker.

so stalled at that point!
0 Kudos
Reply
Robert_P
  • 4.02K
  • 189
  • 370
Forum Team
Forum Team
548 Views
Message 8 of 12
Flag for a moderator

Re: IMEI not recognised

That's strange, the *#06# method is universal across all handsets and should display the IMEI of the phone.

 

Have you been able to speak to BLU in regards to these issues at all?

 

Rob

0 Kudos
Reply
dave10011
  • 7
  • 0
  • 0
Joining in
541 Views
Message 9 of 12
Flag for a moderator

Re: IMEI not recognised

Hi Rob,

Sorry - I think I got myself confused - I have got *#06# to work and it is same as number I read from inside label of phone and when entered into
https://devicesupport.virginmedia.com/customer/imeilookup/
it still says ....

Lookup Result

Sorry, we don't recognise the IMEI you provided.

Please double check and press Back to return to the device picker.

I've only just put the SIM back into the BLU phone - will it take a while for your system to pick that up?
0 Kudos
Reply
Natalie_L
  • 4.58K
  • 182
  • 369
Forum Team
Forum Team
530 Views
Message 10 of 12
Flag for a moderator

Re: IMEI not recognised

Thank you for your reply. 

 

As the device is not ours and the roaming appears to be working when the SIM is in a different phone, it would suggest that the problem lies with the handset. 

 

We would recommend contacting the manufacturer directly or potentially performing a factory reset of the handset if required. 

 

Thanks 

 

 

Nat
0 Kudos
Reply