Showing results for 
Search instead for 
Did you mean: 

I use to have 02 priority but now it's gone

Tuning in

I have virgin broadband and had 02 priority but the other day its not letting  log onto the 02 app. It keeps saying something is wrong and try again later.

I've been trying all week. I miss my daily GREGGS coffee lol

Does anyone know if this option has stopped? 

Who do I contact for help? 






I'm sorry but I'm not signing out of this, deleting that, standing on my head up a corning while spinning around.

The app was working perfectly ok but now doesn't, the question that neither Virgin or 02 can answer is why.


Thanks for coming back to us @chizlit.

Sadly we do need to ask customers to work with us when trying to find a fix for a fault that they're experiencing.

If you're not willing to follow diagnostics, sadly there is little we or our partners over at O2 could do to help further.

Kindest regards,


I have tried all the tips given previously, nothing works.

The question remains who messed with it all and when will it work again?

I assume when 02 take over Virgin there will just be one sign in option.

From what I was told many people were meant to be migrated over to 02 in March, it's now April. 

Hi chizlit,

We're always making changes to make things better and easier for our customers and migrating our customers over to O2 is happening throughout this year. March was never a goalpost to have all customers migrated by though. In fact the very first of our customers were only migrated Mid March. We are continuing this moving forward though and you could receive your communication anytime throughout 2023.​​​​​​ but you will receive it at least 30 days before we move you over to O2.

In the meantime, we want to get things working for you again so please come back with the information asked for in my first post. 

If you're not wanting to, then there is nothing further we can do to help you on this I'm afraid. 

Many thanks,

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Not trying to be funny but it really hasn't made thing better has it?

Just look at all the complaints on the O2 app reviews on playstore .

I'm using a moto g62 5g

Running on 12.

Not sure what other info you want. 

Hi chizlit, 

We will need all the information requested in my first post to you as well as you to try the steps I've popped in there.

You can view the post here

Many thanks, 

Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

Which app version am I using of what?

I've already said I'm using os 12

I'm using Chrome

Yes I have a VPN

Is the device rooted? No idea what this means, it's a mobile I'm using.

As stated all I can do to get the app to work is try to sign in using my Virgin log in which worked previously, now it always comes up with oh looks likes there's an error ( as you've been told by countless others), please try later. 

Hi chizlit, 

Thanks again for coming back to us on this. 

  • The app version we need is the app version of the O2 Priority app that you have downloaded on your device.
  • Can you turn the VPN off to see if this allows the log in to go through?
  • In terms of asking if the device is rooted - this usually means discovering a bug of some sort that allows you to bypass internal protections and gain complete control over the operating system. It can sometimes also be referred to as being jailbroken.
  • Could you please also try signing out of your MyVM App on your phone (by clicking on the dropdown by account name) and then sign in to the O2 Priority App using your VM credentials to see if this rectifies the error you're getting?
  • If that doesn't work then please try logging into your O2 Priority account via a different device and / or browser to see if you can access it from there?

Please, make sure you've signed out of both MyVM and all VM and O2 Apps before you test this though. 

Keep us posted. 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

The O2 app is version 9.1.7.

Signed out of My VM app and tried to open the priority app , as expected same thing popped up.

I don't have a different device to try it on and even if I did that's kind of pointless because I want it to work on the device I'm using.

Oh well perhaps when it all becomes one company in 17 years time it might work. 

Can you try it on a browser for me to see if it works?

Best wishes.

Forum Team

Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill