Menu
Reply
SamBev
  • 4
  • 0
  • 1
Tuning in
210 Views
Message 1 of 8
Flag for a moderator

VM not taking my Direct Debit

Hoping one of the forum team can help get this sorted because I can't get through to customer service. 

I changed banks in June, and updated the new direct debit on the VM website, as instructed. I received an email to confirm the new DD instruction had been set up. 

Despite that, no DD was taken in either July or August, so I made manual payments. I also spoke to a CS agent who confirmed the DD was in place... which it isn't. 

I've since re-entered the details.I'm trying to pay you in a way that doesn't require me to sit on the phone endlessly (Liberty Media is AWFUL in general). 

Can someone please confirm that the DD is actually in place? It should be simple. 

0 Kudos
Reply
newapollo
  • 12.83K
  • 1.71K
  • 3.91K
Very Insightful Person
Very Insightful Person
192 Views
Message 2 of 8
Flag for a moderator
Helpful Answer

Re: VM not taking my Direct Debit

Hi @SamBev 

It can take a day or two for a member of the forum team to pick this and see if they can help you.

Just in case there are further complications  there is a dedicated automated payment line so you don't need to be sat on the phone all day. 

It's 0800 064 3777 and is available to use all day, every day.

Dave

The Service you do for others is the rent you pay for your room here on Earth - Muhammad Ali


I don't work for Virgin Media.

I'm a Very Insightful Person, I'm here to share knowledge. Learn more

Problem solved? Click to mark as a Helpful Answer, or use Kudos to say thanks

The do's and don'ts. Keep the community welcoming for all. Follow the house rules
0 Kudos
Reply
Kain_W
  • 2.18K
  • 64
  • 146
Forum Team
Forum Team
184 Views
Message 3 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Hi there SamBev,

Thanks for your post and welcome to the community.

To clarify, on your MyVM account does the correct information now show?

Let us know,

Kain
SamBev
  • 4
  • 0
  • 1
Tuning in
181 Views
Message 4 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Thanks Kain

It appears to, yes, but I followed the same process a month ago without any success. 

Shall I give it a week to see if it's set up and then post again if no luck?

Best,

SamBev

0 Kudos
Reply
SamBev
  • 4
  • 0
  • 1
Tuning in
178 Views
Message 5 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Thanks - I've followed that route for today's payment

 

Vikki_M
  • 851
  • 24
  • 62
Forum Team
Forum Team
161 Views
Message 6 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Hi @SamBev

 

I would be happy to check the account for you to ensure everything is set up as it should be for you.

 

I will send you a private message so we can do this securely.

 

Please look out for the purple envelope in the top right of the page and pop me a reply when you can. 

Vikki - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


SamBev
  • 4
  • 0
  • 1
Tuning in
140 Views
Message 7 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Thanks Vikki - have dropped you a line
0 Kudos
Reply
Vikki_M
  • 851
  • 24
  • 62
Forum Team
Forum Team
84 Views
Message 8 of 8
Flag for a moderator

Re: VM not taking my Direct Debit

Thank you @SamBev

 

I have responded over private message for you. 

Vikki - Forum Team


New around here? To find out more about the Community check out our Getting Started guide