Showing results for 
Search instead for 
Did you mean: 

Unable to register to MyVM as can’t set a password

Tuning in

I have been experiencing issues for the past week with trying to set a password when trying to register myself for MyVM online as I get the message “You can’t use that password. Please choose another.”

I have tried many different password combinations, different browsers, different devices. Nothing works. I contacted VM via WhatsApp and was told that I was supposed to get a call back from IT support and have not had this. This is really frustrating and I am very disappointed in this service from VM. How are VM going to resolve this?


Forum Team
Forum Team

Hi Roseblossom, 


Welcome to the Community and thank you for getting in touch. 

I am very sorry to hear you are experiencing issues when setting up your online account, we are here to help. 

From your post, I see you have already tried a few steps so I would like to take a closer look from our side. To do this, I will just need to pop you over a private message to confirm a few details. 

The message will be available via the purple envelope on the top right of this page. 

Speak soon,