Showing results for 
Search instead for 
Did you mean: 

Unable to login to myvirginmedia - still loading

Joining in

Everytime I try to login to myvirginmedia (via pc or mobile, and on different browsers) it just stays loading and nothing actually happens. I see this is a common problem. And this is the second time this has happened to me. It is very annoying. Please advise. 

Thankyou, P


Forum Team
Forum Team

Hi Pmr22 👋 welcome to community! Thank you for posting. 

Sorry to hear about these issues with logging in to your My VM account! 👉

If you are able to confirm a few bits of extra information for us this will help identify and resolve the potential issues! Please let us know;

1) What kind of browser you are experiencing the issues on? (Eg Safari, Chrome, Firefox etc)?

2) Have you tried clearing cookies and cache on the devices experiencing the problem?

3) Have you tried refreshing the connection to your network to see if the issue continues?

4) Are you experiencing issues with any other websites or pages?
Following this we will offer some further troubleshooting steps and offer additional support! Thank you for your patience in the meantime 🌞



Hi Molly_T,

I am having the same problem on both Firefox 115.0 and MS Edge 114.0.1823.67 on Windows 10. I authenticate successfully and then get a white page with the animated VM logo in the middle. I can see the three bars icon at the top left, VM logo in the middle and padlock on the right but can't click on anything.

I have disabled the Ghostery add-on, which is installed on Firefox, only but the result is the same.

I have cleared cookies and browser cache in each browser but still the same.

Any advice would be much appreciated, as this isn't my main issue, I'm simply trying to log into MyVM to get support for another VM issue.

Many thanks, Bert.


HI Bert,

Welcome to the Community Forums! Thanks for your post.

Sorry to hear you're having a few issues with our services. We'd very much like to help with both and do our best to get them sorted ASAP!

Do you have the My Virgin Media app, and if so, are you unable to sign into your account from there too? Also, have you tried accessing My Virgin Media over both mobile data and through your home network?

Can you also please tell us what the other issue is so we can assist?

Many thanks