Showing results for 
Search instead for 
Did you mean: 

Unable to login to my account

Joining in

I'm stuck in the same loop that a few others have reported. Going through the registration process tells me that my account exists, but trying to reset the password tells me that the account can't be found:


Any clues as to what to try next?


Problem sorter

I suspect a serious problem with certain accounts. I cannot log in at all due to a ‘something went wrong’ error. I can enter the details, pass captcha then I get the error.

My Broadband Ping - Virginmedia

Forum Team
Forum Team

Hi @l2kphil


Thank you for your post and welcome back to our community.


Have you ever used that email address with us before?


If so, could you please try again using a different email address that has never been used with us previously?


Please pop back to us when you can. 

Vikki - Forum Team

New around here? To find out more about the Community check out our Getting Started guide

Hi Vikki

The email address I'm trying to use is the same one that I use to log in to my Virgin Mobile account.

I've tried going through the registration process using my e-mail address instead, but the outcome is exactly the same, i.e. the system tells me the account is already set up but trying to reset the password tells me the account can't be found.

Forum Team (Retired)
Forum Team (Retired)

Hello @l2kphil,

Can you please confirm if this is for your mobile account or a media account?

Have you been able to access the account before today?

Many thanks,

Forum Team

New around here? To find out more about the Community check out our Getting Started guide

This is for a media account. The mobile account login works fine.

I'm a new customer (service due to be installed on May 3rd) so I'm trying to set up access to my media account before then. 

Hi @l2kphil, thanks for your post although I'm sorry to hear of your concerns raised.

Please allow me to send you a PM to discuss this further and hopefully get you registered ASAP.

Please expect this PM to arrive shortly and respond when you can!

Many thanks


I've had my service up and running since May 3rd, but I still can't create an account for myself. I'm currently getting the same "You can't use that password" error that others have reported. 

Hi l2kphil, 

Apologies this is still ongoing. 

If you don't mind, I will need to send you a private message to pass security. 
If you can check the purple envelope top right of your screen that would be great. 

I'm still not able to log in to my account, any idea when this is going to be fixed? It's been 2 months now since the service was switched on.