Showing results for 
Search instead for 
Did you mean: 

Social Tariff New contract have documents account can't be found

Joining in

I signed up for a social tariff a couple of days ago I received my router, plugged it in, and there's no internet, only a solid blue light. I've tried logging in and other different options, on my email addresses I set up the account I already had an old account but I don't know the details, can someone please help me? I passed everything via the Tom bot, uploaded my ESA entitlement etc, and was supposed to have an active connection by now it even says I passed with a £60 credit limit, I've installed everything correctly, but it can't find my account I have a 1-month rolling contract for £20 a month with a 57mbps UP and 5 - 7mbps DOWN, I am struggling financially and I thought this would be the best option but I have everything installed, a contract with all the details, but no internet. Can someone please help me? But when I use my details or do a router check it says no account found or there isn't even an account. I've tried the Connect app used the forms to check, and used the email address I signed up with and the username and it can't find my account or says I don't have one. I had an old VM account (my sister was paying the bill) but nothing shows up for either of them, on the forums when I used the email address I set up my account with it said that the email was already in use with another account (I had an old VM account, and used my signup email back then to sign up on the forums) so I understand why it says that, but with respect to the new contract it can't find anything. Tried resetting the password, used the area code form and it says there isn't an account, when I do the BB check it says a similar thing.