Menu
Reply
cjames1
  • 3
  • 0
  • 0
Joining in
168 Views
Message 1 of 5
Flag for a moderator

No Bill I for since March?

I have no billing information on my account since March? When I look into my billing history the last bill that appears is March, and if I click on latest bill now it always says £0.00, does anyone have the same issue or know why this is happening? I’m still paying my regular amount and still have internet but it would be nice to be able to see a record of it…

0 Kudos
Reply
Zak_M
  • 4.36K
  • 257
  • 413
Forum Team
Forum Team
145 Views
Message 2 of 5
Flag for a moderator

Re: No Bill I for since March?

Good morning @cjames1 

 

Welcome to the forums and thank you for taking the time to post. 

 

I am really sorry to hear that you have had some issues viewing your billing.

 

Are you able to provide us with a screenshot of the issue? Please cover all personal information.

 

Kind regards.

Zak_M

0 Kudos
Reply
cjames1
  • 3
  • 0
  • 0
Joining in
133 Views
Message 3 of 5
Flag for a moderator

Re: No Bill I for since March?

0A4D0424-5D8F-42A8-83E6-458C012F6511.png

D3A2F01E-3AF6-4470-8AF0-C547A8828694.png

0 Kudos
Reply
cjames1
  • 3
  • 0
  • 0
Joining in
132 Views
Message 4 of 5
Flag for a moderator

Re: No Bill I for since March?

1A04E70A-B9C5-404A-99E8-A617C20CE818.png

0 Kudos
Reply
Zak_M
  • 4.36K
  • 257
  • 413
Forum Team
Forum Team
100 Views
Message 5 of 5
Flag for a moderator

Re: No Bill I for since March?

Thank you for confirming that.

 

This is a little strange, I am going to pop you over a PM so that I can assist you further.

 

Kind regards.

Zak_M

0 Kudos
Reply